zoj 3103 Cliff Climbing(spfa )

Cliff Climbing

Time Limit: 10 Seconds       Memory Limit: 32768 KB

At 17:00, special agent Jack starts to escape from the enemy camp. There is a cliff in between the camp and the nearest safety zone. Jack has to climb the almost vertical cliff by stepping his feet on the blocks that cover the cliff. The cliff has slippery blocks where Jack has to spend time to take each step. He also has to bypass some blocks that are too loose to support his weight. Your mission is to write a program that calculates the minimum time to complete climbing.

Figure D-1 shows an example of cliff data that you will receive. The cliff is covered with square blocks. Jack starts cliff climbing from the ground under the cliff, by stepping his left or right foot on one of the blocks marked with 'S' at the bottom row. The numbers on the blocks are the "slippery levels". It takes t time units for him to safely put his foot on a block marked with t, where 1 <= t <= 9. He cannot put his feet on blocks marked with 'X'. He completes the climbing when he puts either of his feet on one of the blocks marked with 'T' at the top row.


Figure D-1: Example of Cliff Data

Jack's movement must meet the following constraints. After putting his left (or right) foot on a block, he can only move his right (or left, respectively) foot. His left foot position (lxly) and his right foot position (rxry) should satisfy lx <rx and | lx - rx | + | ly - ry | <= 3. This implies that, given a position of his left foot in Figure D-2 (a), he has to place his right foot on one of the nine blocks marked with blue color. Similarly, given a position of his right foot in Figure D-2 (b), he has to place his left foot on one of the nine blocks marked with blue color.


Figure D-2: Possible Placements of Feet

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. Each dataset is formatted as follows:

w h
s(1,1)
 ...  s(1,w)
s(2,1)
 ...  s(2,w)
... 
s(h,1) ...  s(h,w)

The integers w and h are the width and the height of the matrix data of the cliff. You may assume 2 <= w <= 30 and 5 <= h <= 60. Each of the following h lines consists of w characters delimited by a space. The character s(y, x)represents the state of the block at position (xy) as follows:

  • 'S': Jack can start cliff climbing from this block.
  • 'T': Jack finishes climbing when he reaches this block.
  • 'X': Jack cannot put his feet on this block.
  • '1' - '9' (= t): Jack has to spend t time units to put either of his feet on this block.

You can assume that it takes no time to put a foot on a block marked with 'S' or 'T'.

Output

For each dataset, print a line only having a decimal integer indicating the minimum time required for the cliff climbing, when Jack can complete it. Otherwise, print a line only having "-1" for the dataset. Each line should not have any characters other than these numbers.

Sample Input

6 6
4 4 X X T T
4 7 8 2 X 7
3 X X X 1 8
1 2 X X X 6
1 1 2 4 4 7
S S 2 3 X X
2 10
T 1
1 X
1 X
1 X
1 1
1 X
1 X
1 1
1 X
S S
2 10
T X
1 X
1 X
1 X
1 1
1 X
1 X
1 1
1 X
S S
10 10
T T T T T T T T T T
X 2 X X X X X 3 4 X
9 8 9 X X X 2 9 X 9
7 7 X 7 3 X X 8 9 X
8 9 9 9 6 3 X 5 X 5
8 9 9 9 6 X X 5 X 5
8 6 5 4 6 8 X 5 X 5
8 9 3 9 6 8 X 5 X 5
8 3 9 9 6 X X X 5 X
S S S S S S S S S S
10 7
2 3 2 3 2 3 2 3 T T
1 2 3 2 3 2 3 2 3 2
3 2 3 2 3 2 3 2 3 4
3 2 3 2 3 2 3 2 3 5
3 2 3 1 3 2 3 2 3 5
2 2 3 2 4 2 3 2 3 5
S S 2 3 2 1 2 3 2 3
0 0

Sample Output

12
5
-1
22
12


题目并不难,稍微麻烦一点。用spfa能过。

#include"stdio.h"
#include"string.h"
#include"vector"
#include"queue"
#include"iostream"
#include"algorithm"
using namespace std;
#define N 105
const int inf=(int)1e10;
int w,h,ans;
char e[N][N];       
int mark1[N][N],mark2[N][N];  //记录左右脚走到某一点时的最小时间
struct node
{
    int x,y,t,f;     //f记录走到该点是左脚(-1)还是右脚(1)
};
bool judge(int x,int y)     //判断该点是否能走
{
    if(x>=0&&x<h&&y>=0&&y<w&&e[x][y]!='X')
        return true;
    return false;
}
int min(int a,int b)
{
    return a<b?a:b;
}
void spfa()
{
    int i,j,x,y,u,v;
    queue<node>q;
    node cur,next;
    cur.t=0;
    for(i=0;i<h;i++)     //起始点入队,左右脚均可
    {
        for(j=0;j<w;j++)
        {
            if(e[i][j]=='S')
            {
                cur.x=i;
                cur.y=j;
                cur.f=-1;
                q.push(cur);
                cur.f=1;
                q.push(cur);
                mark1[i][j]=mark2[i][j]=0;
            }
        }
    }
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        x=cur.x;
        y=cur.y;
        if(cur.f==1)
        {
            next.f=-1;
            for(i=-2;i<=2;i++)
            {
                for(j=-3;j<=-1;j++)
                {
                    if(abs(i)+abs(j)<=3)
                    {
                        u=x+i;v=y+j;
                        if(judge(u,v))
                        {
                            if(e[u][v]=='T')
                            {
                                ans=min(ans,cur.t);
                                //printf("%d\n",ans);
                                continue;
                            }
                            next.t=cur.t+e[u][v]-'0';
                            if(next.t>=mark1[u][v])
                                continue;
                            next.x=u;
                            next.y=v;
                            mark1[u][v]=next.t;
                            q.push(next);
                        }
                    }
                }
            }
        }
        if(cur.f==-1)
        {
            next.f=1;
            for(i=-2;i<=2;i++)
            {
                for(j=1;j<=3;j++)
                {
                    if(abs(i)+abs(j)<=3)
                    {
                        u=x+i;v=y+j;
                        if(judge(u,v))
                        {
                            if(e[u][v]=='T')
                            {
                                ans=min(ans,cur.t);
                                //printf("%d\n",ans);
                                continue;
                            }
                            next.t=cur.t+e[u][v]-'0';
                            if(next.t>=mark2[u][v])
                                continue;
                            next.x=u;
                            next.y=v;
                            mark2[u][v]=next.t;
                            q.push(next);
                        }
                    }
                }
            }
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&w,&h),w||h)
    {
        for(i=0;i<h;i++)
        {
            for(j=0;j<w;j++)
            {
                cin>>e[i][j];
                mark1[i][j]=mark2[i][j]=inf;
            }
        }
        ans=inf;
        spfa();
        if(ans>=inf)
            printf("-1\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值