poj 1122 FDNY to the Rescue! (dijkstra)

FDNY to the Rescue!
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2475 Accepted: 755

Description

The Fire Department of New York (FDNY) has always been proud of their response time to fires in New York City, but they want to make their response time even better. To help them with their response time, they want to make sure that the dispatchers know the closest firehouse to any address in the city. You have been hired to write this software and are entrusted with maintaining the proud tradition of FDNY. Conceptually, the software will be given the address of the fire, the locations of the firehouses, street intersections, and the time it takes to cover the distance between each intersection. It will then use this information to calculate how long it takes to reach an address from each firehouse. 

Given a specific fire location in the city, the software will calculate the time taken from all the fire stations located in the city to reach the fire location. The list of fire stations will be sorted from shortest time to longest time. The dispatcher can then pick the closest firestation with available firefighters and equipment to dispatch to the fire.

Input

Line 1: 
# of intersections in the city, a single integer (henceforth referred to as N) N<20 

Lines 2 to N+1: 
A table (square matrix of integer values separated by one or more spaces) representing the time taken in minutes between every pair of intersections in the city. In the sample input shown below the value "3" on the 1st row and the 2nd column represents the time taken from intersection #1 to reach intersection #2. 

Similarly the value "9" on the 4th row and the 2nd column represents the time taken from intersection #4 to reach intersection #2. 

A value of -1 for time means that it is not possible to go directly from the origin intersection (row #) to the destination intersection (column #). All other values in the table are non-negative. 

Line N+2: 
An integer value n (<= N) indicating the intersection closest to the fire location followed by one or more integer values for the intersections closest to the fire stations (all on one line, separated by one or more spaces) will follow the input matrix. 

Notes on input format: 

1. The rows and columns are numbered from 1 to N. 
2. All input values are integers 
3. All fire locations are guaranteed reachable from all firehouses. 
4. All distance calculations are made from the intersection closest to each firehouse to the intersection closest to the fire. 

Output

Line 1: 
A label line with the headings for each column, exactly as shown in the example. 

Line 2 onwards (one line for each fire station): 
A sorted list (based on time) showing the fire station (origin), the destination site, time taken and a complete shortest path of nodes from the originating fire station to the fire location. 

Notes on output format: 
1. Columns are tab separated. 
2. If two or more firehouses are tied in time they can be printed in any order. 
3. If more than one path exists that has the same minimal time for a given location & firehouse, either one can be printed on the output. 
4. If the fire location and the fire station locations happen to be the same intersection, the output will indicate that the origin and destination have the same intersection number, the time will be "0" and the nodes in the shortest path will show just one number, the fire location. 
Next is the picture for the sample input data. 

Sample Input

6 
0  3  4 -1 -1 -1 
-1 0  4  5 -1 -1 
2  3  0 -1 -1  2 
8  9  5  0  1 -1 
7  2  1 -1  0 -1 
5 -1  4  5  4  0 
2  4  5  6 
In the above input the last line indicates that "2" is the location of the fire and "4", "5" and "6" are the intersections where fire stations are located. 

Sample Output

Org	Dest	Time	Path
5	2	2	5	2
4	2	3	4	5	2
6	2	6	6	5	2

Source


题意:求各个消防点到失火点的距离和到达该点的路径。

思路:dijkstra求最短路,因为失火点只有一个,故可以求失火点到消防局的最短路,读入反向边。


#include"stdio.h"
#include"string.h"
#include"queue"
#include"algorithm"
using namespace std;
#define N 25
#define inf 0x7fffffff
int mark[N],g[N][N];
int dis[N],pre[N],n;  //记录最短路,记录路线
struct node
{
    int id,d;  //记录消防局小标和距离
}a[N];
bool cmp(node a,node b)
{
    return a.d<b.d;
}
void dijkstra(int s)
{
    int i,min,u;
	memset(pre,-1,sizeof(pre));
    for(i=1;i<=n;i++)
    {
        pre[i]=s;
        dis[i]=g[s][i];
        mark[i]=0;
    }
    mark[s]=1;
    while(1)
    {
        min=inf;
        u=s;
        for(i=1;i<=n;i++)
        {
            if(min>dis[i]&&!mark[i])
            {
                min=dis[i];
                u=i;
            }
        }
        if(u==s)
            break;
        mark[u]=1;
        for(i=1;i<=n;i++)
        {
            if(!mark[i]&&g[u][i]<inf&&g[u][i]+dis[u]<dis[i])
            {
                dis[i]=g[u][i]+dis[u];
                pre[i]=u;
            }
        }
    }
}
void work(int k)
{
    int i,j;
    a[0].d=-1;
    for(i=1;i<k;i++)
    {
        a[i].d=dis[a[i].id];
    }
    sort(a,a+k,cmp);
    printf("Org	Dest	Time	Path\n");
    for(i=1;i<k;i++)
    {
        printf("%d	%d	%d	%d	",a[i].id,a[0].id,a[i].d,a[i].id);
        for(j=pre[a[i].id];j!=a[0].id;j=pre[j])
        {
            printf("%d	",j);
        }
		if(a[i].id!=a[0].id)      //失火点和消防点相同
	        printf("%d\n",a[0].id);
		else
			printf("\n");
    }
}
int main()
{
    int i,j,t,k;
    char str[500];
    while(scanf("%d",&n)!=-1)
    {
        for(i=1;i<=n;i++) 
        {                  
            for(j=1;j<=n;j++)
            {
                scanf("%d",&g[j][i]);
                if(g[j][i]<0)   
                    g[j][i]=inf;
            }
        }
        gets(str);      
        gets(str);   
        t=k=0;
        for(i=0;str[i]!='\0';i++)
        {
            if(str[i]>='0'&&str[i]<='9')
            {
                t=t*10+str[i]-'0';
            }
            else if(t!=0)
            {
                a[k++].id=t;
                t=0;
            }
        }
		if(t!=0)      //末尾还有一个
			a[k++].id=t;
        memset(pre,-1,sizeof(pre));
        dijkstra(a[0].id);
        work(k);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值