hdu 4771 Stealing Harry Potter's Precious (bfs+状态压缩)

Stealing Harry Potter's Precious

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1297    Accepted Submission(s): 619


Problem Description
  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.
 

Input
  There are several test cases.
  In each test cases:
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.
  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).
  The input ends with N = 0 and M = 0
 

Output
  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.
 

Sample Input
  
  
2 3 ##@ #.# 1 2 2 4 4 #@## .... #### .... 2 2 1 2 4 0 0
 

Sample Output
  
  
-1 5


思路:用一个三维数组记录拿到某些宝物后的状态,存储拿到某些宝物后的最短时间。


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
#define N 105
#define M 30000
const int inf=(int)1e8;
char g[N][N];
int a[N][N];        //记录每个宝物的编号
int mark[N][N][32];
int k,n,m,l,ans;
int dir[4][2]={0,1,0,-1,-1,0,1,0};
struct node
{
    int x,y,s,t;  //状态和时间
    int num;    //宝物数量
    friend bool operator<(node a,node b)
    {
        return a.t>b.t;
    }
};
bool judge(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m||g[x][y]=='#')
        return true;
    return false;
}
void inti()   //初始化数组,时间为无穷大
{
    int i,j,k;
    for(i=0;i<n;i++)
    {
        for(j=0;j<m;j++)
        {
            for(k=0;k<l;k++)
            {
                mark[i][j][k]=inf;
            }
        }
    }
}
void bfs(int x,int y)
{
    int i,di,dj;
    priority_queue<node>q;
    node cur,next;
    cur.t=cur.s=cur.num=0;
    cur.x=x;
    cur.y=y;
    mark[x][y][0]=0;
    q.push(cur);
    while(!q.empty())
    {
        cur=q.top();
        q.pop();
        for(i=0;i<4;i++)
        {
            next.x=di=cur.x+dir[i][0];
            next.y=dj=cur.y+dir[i][1];
            next.t=cur.t+1;
            next.s=cur.s;
            next.num=cur.num;
            if(judge(di,dj))
                continue;
            int t=a[di][dj];
            if(t!=-1&&(next.s&(1<<t))==0)
            {
                next.s|=(1<<t);
                next.num++;
                if(next.num==k)
                {
                    ans=min(ans,next.t);
                    return ;
                }
            }
            if(mark[di][dj][next.s]>next.t)
            {
                mark[di][dj][next.s]=next.t;
                q.push(next);
            }
        }
    }
}
int main()
{
    int i,j,x,y;
    int si,sj;
    while(scanf("%d%d",&n,&m),n||m)
    {
        for(i=0;i<n;i++)
        {
            scanf("%s",g[i]);
            for(j=0;j<m;j++)
            {
                if(g[i][j]=='@')
                {
                    si=i;sj=j;
                }
            }
        }
        scanf("%d",&k);
        memset(a,-1,sizeof(a));
        for(i=0,l=1;i<k;i++)  
        {
            scanf("%d%d",&x,&y);
            a[x-1][y-1]=i;
            l=l<<1;      //最多4个宝物,故状态的最大值为1111,
        }                //l为总的状态数加一
        inti();
        ans=inf;
        bfs(si,sj);
        if(ans==inf)
            ans=-1;
        printf("%d\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值