pairs(HDU-5178)

Problem Description

John has nn points on the X axis, and their coordinates are  (x[i],0),(i=0,1,2,…,n−1) . He wants to know how many pairs<a,b><a,b> that |x[b]-x[a]|\leqslant k,a< b

Input

The first line contains a single integer T (about 5), indicating the number of cases. 
Each test case begins with two integers n,k(1≤n≤100000,1≤k≤109). 
Next n lines contain an integer x[i](−109≤x[i]≤109), means the X coordinates.

Output

For each case, output an integer means how many pairs<a,b> that |x[b]-x[a]|\leqslant k

Sample Input

2
5 5
-100
0
100
101
102
5 300
-100
0
100
101
102

Sample Output

3
10

题意:给出 n 个数,问有多少对 <a,b> 满足 |x[b]-x[a]|\leqslant k,a< b

思路:尺取法

|x[b]-x[a]|\leqslant k 去掉绝对值,得:x[a]-k \leq x[b] \leq x[a]-k

对 n 个数排序后使用,对相邻的数尺取即可

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define PI acos(-1.0)
#define E 1e-9
#define INF 0x3f3f3f3f
#define N 100001
#define LL long long
const int MOD=20091226;
const int dx[]= {-1,1,0,0};
const int dy[]= {0,0,-1,1};
using namespace std;
LL a[N];
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        LL k;
        scanf("%d%lld",&n,&k);
        for(int i=1;i<=n;i++)
            scanf("%lld",&a[i]);

        sort(a+1,a+1+n);

        LL res=0;
        int l=1,r=1;
        while(l<=n){
            while(r+1<=n&&a[r+1]-a[l]<=k)
                r++;
            res+=(r-l);
            l++;
        }
        printf("%lld\n",res);
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值