骨牌覆盖(51Nod-1031)

题目

在2*N的一个长方形方格中,用一个1*2的骨牌排满方格。
问有多少种不同的排列方法。

例如:2 * 3的方格,共有3种不同的排法。(由于方案的数量巨大,只输出 Mod 10^9 + 7 的结果)

输入

输入N(N <= 1000)

输出

输出数量 Mod 10^9 + 7

输入样例

3

输出样例

3

思路:具体思路见 骨牌铺方格(HDU-2046),注意取模

源程序

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define EPS 1e-9
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
const int MOD=1E9+7;
const int N=50000+5;
const int dx[]= {-1,1,0,0};
const int dy[]= {0,0,-1,1};
using namespace std;

int main(){
    LL n;
    scanf("%lld",&n);
    LL a=1,b=2;
    for(int i=3;i<=n;i++){
        LL c=b%MOD;
        b=(a+b)%MOD;
        a=c%MOD;
    }
    if(n==1)
        b=a;
    printf("%lld",b);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值