Boxes and Candies(AtCoder-2152)

Problem Description

There are N boxes arranged in a row. Initially, the i-th box from the left contains ai candies.

Snuke can perform the following operation any number of times:

Choose a box containing at least one candy, and eat one of the candies in the chosen box.
His objective is as follows:

Any two neighboring boxes contain at most x candies in total.
Find the minimum number of operations required to achieve the objective.

Constraints

  • 2≤N≤105
  • 0≤ai≤109
  • 0≤x≤109

Input

The input is given from Standard Input in the following format:

N x
a1 a2 … aN

Output

Print the minimum number of operations required to achieve the objective.

Example

Sample Input 1

3 3
2 2 2

Sample Output 1

1
Eat one candy in the second box. Then, the number of candies in each box becomes (2,1,2).

Sample Input 2

6 1
1 6 1 2 0 4

Sample Output 2

11
For example, eat six candies in the second box, two in the fourth box, and three in the sixth box. Then, the number of candies in each box becomes (1,0,1,0,0,1).

Sample Input 3

5 9
3 1 4 1 5

Sample Output 3

0
The objective is already achieved without performing operations.

Sample Input 4

2 0
5 5

Sample Output 4

10
All the candies need to be eaten.

题意:n 个盒子,每个盒子里有 a[i] 个糖,现在每次可以吃掉一个盒子中的一个糖,问最少吃多少个糖后,使得任意相邻盒子中的糖不会超过 x

思路:

贪心,从第一个开始枚举,每次贪当前盒子右边的盒子,保证两个盒子中的糖果数不会超过 x 即可,如果超过,就计算差值累加吃糖次数,并改变右边盒子糖果个数,注意最后一个特判以及 long long

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define EPS 1e-9
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
const int MOD = 1E9+7;
const int N = 1000000+5;
const int dx[] = {0,0,-1,1,-1,-1,1,1};
const int dy[] = {-1,1,0,0,-1,1,-1,1};
using namespace std;
LL a[N];
int main() {
    LL n,x;
    scanf("%lld%lld",&n,&x);
    for(int i=1;i<=n;i++)
        scanf("%lld",&a[i]);

    LL res=0;
    for(int i=1;i<=n-1;i++){
        if(a[i]+a[i+1]>x){
            LL sub=a[i]+a[i+1]-x;
            a[i+1]-=sub;
            res+=sub;
        }
    }
    if(a[n]>x)
        res+=a[n]-x;

    printf("%lld\n",res);

    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值