Factors of Factorial(AtCoder-2286)

Problem Description

You are given an integer N. Find the number of the positive divisors of N!, modulo 109+7.

Constraints

  • 1≤N≤103

Input

The input is given from Standard Input in the following format:

N

Output

Print the number of the positive divisors of N!, modulo 109+7.

Example

Sample Input 1

3

Sample Output 1

4
There are four divisors of 3! =6: 1, 2, 3 and 6. Thus, the output should be 4.

Sample Input 2

6

Sample Output 2

30

Sample Input 3

1000

Sample Output 3

972926972

题意:给出一个整数 n,求 n! 的约数个数

思路:

根据唯一分解定理,一个整数 n 可分解为:n=p_1^{a_1}*p_1^{a_2}*...*p_k^{a_k}

那么,n 的约数个数为:(1+a_1)*(1+a_2)*....*(1+a_k)

故而对于每个素因子,可以选择 0~ai 个,根据乘法原理,直接统计即可

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define EPS 1e-9
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
const int MOD = 1E9+7;
const int N = 1000+5;
const int dx[] = {0,0,-1,1,-1,-1,1,1};
const int dy[] = {-1,1,0,0,-1,1,-1,1};
using namespace std;
int num[N];
int main() {
    int n;
    scanf("%d",&n);
    for(int i=2;i<=n;i++){
        int temp=i;
        for(int j=2;j<=temp;j++){
            while(temp%j==0){
                num[j]++;
                temp/=j;
            }
        }
        if(temp!=1)
            num[temp]++;
    }

    LL res=1;
    for(int i=1; i<=n; i++)
        if(num[i])
            res=(res*(num[i]+1))%MOD;
    printf("%lld\n",res);

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值