B - Factors of Factorial AtCoder - 2286

Problem Statement

You are given an integer N. Find the number of the positive divisors of N!, modulo 109+7.

Constraints

  • 1N103
Input

The input is given from Standard Input in the following format:

N
Output

Print the number of the positive divisors of N!, modulo 109+7.

Sample Input 1

3
Sample Output 1

4

There are four divisors of 3! =6123 and 6. Thus, the output should be 4.

Sample Input 2

6
Sample Output 2

30
Sample Input 3

1000
Sample Output 3

972926972

N!=2^a*3^b*5^c*7^d......

所以约数个数为(a+1)*(b+1)*(c+1).........

AC:

#include<stdio.h>

#include<string.h>
int mod=1e9+7;
int main()
{
int n,i,x,j;
int a[10005];
scanf("%d",&n);
memset(a,0,sizeof(a));
for(i=2;i<=n;i++)
{
x=i;
for(j=2;j<=x;j++)
{
while(x%j==0)
{
a[j]++;
x/=j;
}
}
if(x!=1) a[x]++;
}
long long sum;
sum=1;
for(i=1;i<=n;i++)
{
if(a[i]!=0)
 sum=(sum*(a[i]+1))%mod;
}
printf("%lld\n",sum);
return 0;
 } 
 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值