ACM杭电1005 Number Sequence

20 篇文章 0 订阅
2 篇文章 0 订阅
Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5

刚开始读这道题觉得很简单,就是一个公式而已,然后带进去翻译成代码即可,结果交了一次WA,然后找问题,才发现这个公式是个周期函数,于是自己打表,从1 1到10 10虽然没有全部打表,但也打了大部分,后面发现 7 7全0后面的8 8就与1 1重合了,于是感觉这是个周期函数,每套数据48个,然后就用nmod49让n能取到48。代码如下:

#include<iostream>
#include<math.h>
using namespace std;
const int MAX_N=100000005;
int f[MAX_N];
int main()
{
	int A,B,n;
	while (cin>>A>>B>>n)
	{
		int T=0;
		int f1=0;
		f[0]=0;
		f[1]=1;f[2]=1;
		if(A==0&&B==0&&n==0)
			break;
		A=A%7;
		B=B%7;
		n=n%49;
		for(int i=3;i<=n;++i)
		{
			f[i]=(A*f[i-1]+B*f[i-2])%7;
		}
		if(A==7&&B==7)
			cout<<"0"<<endl;
		if(A==0&&B==0)
			cout<<"0"<<endl;
		else
		   cout<<f[n]<<endl;
		
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值