PAT (Advanced Level) Practice 1032 Sharing(25分)【链表】

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

在这里插入图片描述
Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N ( ≤ 1 0 5 ) N (≤10^5) N(105), where the two addresses are the addresses of the first nodes of the two words, and N N N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by − 1 −1 1.

Then N N N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

题意

找出两个链表的后缀的第一个节点的位置。

思路

使用静态链表保存节点。从第一个单词的起始位置开始遍历一次,再从第二个单词的起始位置开始遍历,如果遇到了第一次已经遍历过的节点,那么这个节点就是答案。节点存储的字符实际上没有意义,可以忽略。

代码

#include <iostream>
#include <iomanip>

using namespace std;

struct {
    int next;
    bool vis;
} node[100005];

int main() {
    int a, b, n;
    cin >> a >> b >> n;

    for (int i = 0; i < n; i++) {
        int id, ne;
        char d;
        cin >> id >> d >> ne;

        node[id].next = ne;
    }

    for (int pos = a; pos != -1; pos = node[pos].next)
        node[pos].vis = 1;

    int ans = -1;
    for (int pos = b; pos != -1; pos = node[pos].next) {
        if (node[pos].vis == 1) {
            ans = pos;
            break;
        }
    }

    if (ans == -1)
        cout << -1;
    else  // 注意格式
        cout << setw(5) << setfill('0') << ans;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值