HDU2717:Catch That Cow(BFS)

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


BFS水题
问的是The least amount of time,也就是最少时间,BFS妥妥的


</pre><pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int N=100000;
int vis[N+10];
int dir[2]={1,-1};
int n,k;
struct node
{
	int l,step;
};
node s ;
int bfs()
{
	node pt,pn;
	memset(vis,0,sizeof(vis));
	queue<node>Q;
	Q.push(s);
	while(!Q.empty())
	{
		pt=Q.front();
		Q.pop();
		if(pt.l==k)
			return pt.step;
		for(int i=0;i<3;++i)
		{
			pn.l=pt.l+(i!=2?dir[i]:pt.l);
			if(pn.l>=0&&pn.l<=N&&!vis[pn.l])
			{
				pn.step=pt.step+1;
				vis[pn.l]=1;
				Q.push(pn);
			}
		}
	}
	return -1;//之前return 0;居然过不了...是我英语太水看不懂题目的缘故?
}
int main()
{
	while(~scanf("%d%d",&n,&k))
	{
		s.l=n;
		s.step=0;
		vis[n]=1;
		int ans=bfs();
		printf("%d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值