HDU1690:Bus System(Floyd)

Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

Sample Input
  
  
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

Sample Output
  
  
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
注意测试数据的值很大!!!
#include<stdio.h>
const __int64 inf=1e18;
__int64 map[110][110],x[110];
__int64 n;
__int64 l[4],c[4];
__int64 abs(__int64 x)
{
	return x<0?-x:x;
}
__int64 cost(__int64 x)
{
	if(x<=l[0])
		return c[0];
	if(x<=l[1])
		return c[1];
	if(x<=l[2])
		return c[2];
	if(x<=l[3])
		return c[3];
	return inf;
}
void Floyd()
{
	__int64 i,j,k;
	for(k=1;k<=n;k++)
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				if(map[i][j]>map[i][k]+map[k][j])
					map[i][j]=map[i][k]+map[k][j];
}
int main()
{
//	freopen("testin.txt","r",stdin);
//freopen("testout.txt","w",stdout);
	__int64 m,t,i,j,cas=0;
	scanf("%d",&t);
	while(t--)
	{
		for(i=0;i<4;i++)
			scanf("%I64d",&l[i]);
		for(i=0;i<4;i++)
			scanf("%I64d",&c[i]);
		scanf("%I64d%I64d",&n,&m);
		for(i=1;i<=n;i++)
			scanf("%I64d",&x[i]);
		for(i=0;i<=n;i++)
		{
			map[i][i]=0;
			for(j=i+1;j<=n;j++)
				map[j][i]=map[i][j]=inf;
		}
		for(i=1;i<=n;i++)
			for(j=i+1;j<=n;j++)
				map[j][i]=map[i][j]=cost(abs(x[i]-x[j]));
		Floyd();
		printf("Case %d:\n",++cas);
		__int64 u,v;
		while(m--)
		{
			scanf("%I64d%I64d",&u,&v);
			if(map[u][v]==inf)
				printf("Station %I64d and station %I64d are not attainable.\n",u,v);
			else
				printf("The minimum cost between station %I64d and station %I64d is %I64d.\n",u,v,map[u][v]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值