背包问题(2)01背包 Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22998    Accepted Submission(s): 9320


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14

思路:比上个问题更水的背包问题, 因看错了volume 和 value 而抑郁了半天(侧面说明English 

is very important!!!), 用 ans[i][j] 表示前i个物品在容量为j的背包里的最优解, 每个问题可以分解成两个子问题的和(第i个物品放或不放):ans[i-1][j] 前i-1个物品放入容量为j的背包里的最优解, 和ans[i-1][j - weight[i]] + value[i], 将第i个物品加入到背包内, 递推式为:f[i][v]=max{f[i-1][v],f[i-1][v-c[i]]+w[i]}。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAX 1005

int ans[MAX][MAX], weight[MAX], value[MAX];

int mymax(int a, int b)
{
    return a > b ? a : b;
}

int main()
{
    int t, n, v, i, j;                                    //变量见题目
	scanf("%d", &t);
	while(t--)
	{
		memset(ans, 0, sizeof(ans));                       //每次清空
		scanf("%d%d", &n, &v);
		for(i = 1; i <= n; i++)
		{
		    scanf("%d", &value[i]);
		}
		for(i = 1; i <= n; i++)
		{
		    scanf("%d", &weight[i]);
		}
		for(i = 1; i <= n; i++)
		{
		    for(j = 0; j <= v; j++)
			{
				if(j < weight[i])                           //在j < weight[i] 时无法加入, 保存(i-1)的解
				{
				    ans[i][j] = ans[i-1][j];
				}
				else                                         //否则取最优解(加或不加)
				{
			        ans[i][j] = mymax(ans[i-1][j], ans[i-1][j-weight[i]] + value[i]);
				}
			}
		}
		printf("%d\n", ans[n][v]);                          //最优解
	}
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值