POJ 2240 Arbitrage(最短路Floyed)

Arbitrage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16292 Accepted: 6850

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". 

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No


解题思路:这道题主要是找到能够让货币增值的路径,只要找到无限循环就可以无限增值。对于这种问题,显然是使用Bellman_ford或者Floyed。数据量不大,用Floyed过。

/**********************************/
/*Problem: 2240  User: shinelin   */
/*Memory: 232K  Time: 79MS        */
/*Language: C++  Result: Accepted */
/**********************************/
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <ctype.h>
#include <cstring>
#include <string>
#include <list>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;

#define MAXN 36
#define INF  65535

string cur[MAXN];
double Rate[MAXN][MAXN];
int T, M;

map<string, int> ma;

int main()
{
    string a, b, x;
    double rate;
    double Money[MAXN];
    int cnt = 1;
    while(scanf("%d", &T) != EOF, T)
    {
        ma.clear();
        memset(Money, 0, sizeof(Money));
        memset(Rate, 0, sizeof(Rate));

        for (int i = 1; i <= T; i ++)
        {
            cin >> x;
            ma.insert(make_pair(x, i));
        }
        for (int i = 1; i <= T; i++)
        {
            Rate[i][i] = 1;
        }
        scanf("%d", &M);
        for(int i = 0; i < M; i ++)
        {
            cin >> a >> rate >> b;
            Rate[ma[a]][ma[b]] = rate;
        }
        int flag = 0;
         printf("Case %d: ", cnt ++);
        for(int k = 1; k <= T; k ++)
        {
            for (int i = 1; i <= T; i ++)
            {
                for (int j = 1; j <= T; j ++)
                {
                    if(Rate[i][j] < Rate[i][k] * Rate[k][j])
                    {
                        Rate[i][j] = Rate[i][k] * Rate[k][j];
                        if(Rate[i][i] > 1|| Rate[j][j] > 1)
                        {
                            printf("Yes\n");
                            flag = 1;
                            break;
                        }
                    }
                }
                if(1 == flag) break;
            }
            if(1 == flag) break;
        }
        if(!flag)
        {
            printf("No\n");
        }
    }
    return 0;
}

心得:定义变量的时候注意类型,今天又在这里渣渣了。。。然后要顺便复习一下map的用法,毕竟很好的一个数据结构。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值