ZOJ Problem Set - 2750

Idiomatic Phrases Game

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

Sample Input

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

Sample Output

17
-1
 
这道题目就是比较裸的dijkstra了,首先输入字符串,获取前4个字符和后4个字符,然后建图。之后从第1个字符开始来一遍dijkstra,来获得1是否可达n。
 
代码:
#include<cstdio>
#include<iostream>
#include<cstring>
#define Maxn 1010
using namespace std;

struct word{
    char pre[5],suf[5];
    int w;
}p[Maxn];
char s[Maxn];
int adj[Maxn][Maxn],dist[Maxn],vis[Maxn];
const int inf=0x3f3f3f3f;
void dijkstra(int u,int n){
    bool flag=true;
    for(int i=0;i<n;i++)
        dist[i]=adj[u][i],vis[i]=0;
    vis[u]=1;
    for(int i=1;i<n;i++){
        int minn=inf,v=0;
        for(int j=0;j<n;j++)
            if(!vis[j]&&dist[j]<minn)
                minn=dist[j],v=j;
        vis[v]=1;
        for(int j=0;j<n;j++)
            if(!vis[j]&&dist[v]+adj[v][j]<dist[j])
                dist[j]=dist[v]+adj[v][j];
    }
    printf("%d\n",dist[n-1]!=inf?dist[n-1]:-1);
}
int main()
{
    int n;
    while(scanf("%d",&n),n){
        for(int i=0;i<n;i++){
            scanf("%d%s",&p[i].w,s);
            int len=strlen(s);
            for(int j=0;j<4;j++)
                p[i].pre[j]=s[j],p[i].suf[j]=s[len-4+j];
            p[i].pre[4]=p[i].suf[4]='\0';
        }
        memset(adj,0x3f,sizeof adj);
        for(int i=0;i<n;i++) adj[i][i]=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++){
                if(i==j) continue;
                if(!strcmp(p[i].suf,p[j].pre))
                    adj[i][j]=p[i].w;
            }
        dijkstra(0,n);
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值