Tree Recovery poj 2255 c++

 

Tree Recovery

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11421 Accepted: 7167

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

Input

The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

 

 

题意:给你一个树的先序和中序,输出后序序列;

思路:不断的递归,每次把找出的根存进数组,输出即可;

#include<cstdio>
#include<cstring>

char a[1010],b[1010],c[1010];
void build_tree(int n, char *a, char *b, char *c)
{
     int len=0;
     char *p=b;
     if(n<=0)
        return ;
     while(1)
     {
        if(a[0]==*p) 
           break;
        else 
           p++;
     }
     len=p-b;
     build_tree(len,a+1,b,c);
     build_tree(n-len-1,a+len+1,b+len+1,c+len);   
     c[n-1]=a[0]; 
} 

int main()
{
    int n,i;
    while(scanf("%s%s",a,b)!=EOF)
    {
        getchar();
        n=strlen(a);
        build_tree(n,a,b,c);  
        for(i=0;i<n;i++)
           printf("%c",c[i]); 
        printf("\n");   
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值