POJ-1129 Channel Allocation 解题报告

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11402 Accepted: 5840

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

Source


解题思路:

扫描每一个节点,对该节点的联通节点进行检测,如果已经着色就向color数组中写入,否则继续扫描,这样,会找到该节点应该着色的最小值.

//思想:扫描节点a周围的节点,然后将这些节点的颜色分别写入color中
//然后将最小未用颜色写入节点a


#include <iostream>
#include <vector>
#include <string>
using namespace std;

#define maxN 30
int Max=0;
int color[maxN];
vector<int> vec[maxN];

int sulotion(int n){
    int minuse=0;
    for (int i=0; i<n; ++i){
        memset(color,0,sizeof(color));
        
        for (int j = 1; j < vec[i].size(); j++){
            int adjpos = vec[i][j];
            if (vec[adjpos][0]==-1) continue;
            color[vec[adjpos][0]]=1;
        }
        int j=-1;
        //找到最小未被使用的颜色
        while ( color[++j] ) ;
        //着色
        vec[i][0]=j;
        minuse = minuse>j?minuse:j;
    }
    return minuse+1;
}

int main()
{
    int n;
    cin>>n;
    string s;
    while ( n  ){
        for ( int i=0; i<n;++i ){
            vec[i].clear();
        }
        for ( int i=0; i<n; ++i ){
            cin>>s;
            for ( int j=0; j<s.length();++j ){
                if ( s[j]==':' ) continue;
                vec[i].push_back(s[j]-'A');
            }
            vec[i][0]=-1;
        }
        int num = sulotion(n);
        if (num==1)
            cout<<num<<" channel needed."<<endl;
        if ( num>1 )
            cout<<num<<" channels needed."<<endl;
        cin>>n;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值