hdu2476 String painter

Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
 

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
 

Output
A single line contains one integer representing the answer.
 

Sample Input
  
  
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd
 

Sample Output
  
  
6 7
 

题意:给出两串字符,要你将第一串字符变成第二串字符,每次可以改变连续的一个或多个字符,求最少的修改次数。


#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
int dp[110][110];
char a[110],b[110];
int main()
{
    int i,j,k,m,n;
    while(scanf("%s %s",a+1,b+1)==2)
    {
        memset(dp,0,sizeof(dp));
        int len=strlen(a+1);
        for(i=1;i<=len;i++) dp[i][i]=1;
        for(i=len-1;i>=1;i--)
            for(j=i+1;j<=len;j++)
            {
                dp[i][j]=dp[i+1][j]+1;
                for(k=i+1;k<=j;k++)
                    if(b[i]==b[k])
                    dp[i][j]=min(dp[i][j],dp[i+1][k-1]+dp[k][j]);
            }
        for(i=1;i<=len;i++)
        {
            if(a[i]==b[i]) dp[1][i]=dp[1][i-1];
            else
                for(j=1;j<i;j++)
                dp[1][i]=min(dp[1][i],dp[1][j]+dp[j+1][i]);
        }
        printf("%d\n",dp[1][len]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值