poj2299 Ultra-QuickSort(树状数组求逆序数,离散化)

所谓数列的逆序数就是一个值sum,sum=b[0]+b[1]+...+b[n-1]。这里假设数列为a,其中b[i]表示在数列中在a[i]后面并且比a[i]小的数的个数。比如有数列 2 8 0 3的逆序数就是1+2+0+0=3。

Description
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0
Sample Output
6
0

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<memory.h>
using namespace std;
const int Max=500010;
struct node
{
    int index;
    int v;
};
node we[Max];
int b[Max];
int c[Max];
int n;
bool cmp(node a,node b)
{
    return a.v<b.v;
}
int lowbit(int i)
{
    return i&(-i);
}
void update(int i,int x)
{
    while(i<=n)
    {
        c[i]+=x;
        i+=lowbit(i);
    }
}
int Sum(int i)
{
    int sum=0;
    while(i>0)
    {
        sum+=c[i];
        i-=lowbit(i);
    }
    return sum;
}
int main()
{
    while(cin>>n&&n)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&we[i].v);
            we[i].index=i;
        }
        sort(we+1,we+n+1,cmp);
        b[we[1].index]=1;
        for(int j=2;j<=n;j++)//离散化(数据变小,但相对大小不变)
        {
            if(we[j].v==we[j-1].v)
                b[we[j].index]=b[we[j-1].index];
            else
                b[we[j].index]=j;
        }
        memset(c,0,sizeof(c));
        long long num=0;
        for(int k=1;k<=n;k++)//树状数组求逆序数
        {
            update(b[k],1);
            num+=Sum(n)-Sum(b[k]);
        }
        cout<<num<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值