hdu5167 Fibonacci set和map

Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1857    Accepted Submission(s): 467


Problem Description
Following is the recursive definition of Fibonacci sequence:
Fi=01Fi1+Fi2i = 0i = 1i > 1

Now we need to check whether a number can be expressed as the product of numbers in the Fibonacci sequence.
 

Input
There is a number  T  shows there are  T  test cases below. ( T100,000 )
For each test case , the first line contains a integers n , which means the number need to be checked. 
0n1,000,000,000
 

Output
For each case output "Yes" or "No".
 

Sample Input
  
  
3 4 17 233
 

Sample Output
  
  
Yes No Yes
 


#include<iostream>
#include<cstring>
#include<cstdio>
#include<ostream>
#include<istream>
#include<algorithm>
#include<queue>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<stack>
#include<vector>
#define fi first
#define se second
#define ll long long
#define pii pair<int,int>
#define inf (1ll<<60)
#define eps 1e-8
#define pb push_back
using namespace std;
const int maxn=110005;
int n;
ll d[1000];
map<ll,int>mp;
set<ll>se;
void gao()
{
    ll N=1000000000;
    queue<ll>que;
    for(int i=0;i<=45;i++) {
        que.push(d[i]);
        mp[d[i]]=1;
        se.insert(d[i]);
    }
    while(!que.empty()) {
        ll u=que.front();
        que.pop();
        for(int i=3;i<=45;i++) {
            ll v=u*d[i];
            if(v>N)
                break;
            if(mp.count(v))
                continue;
            mp[v]=1;
            que.push(v);
            se.insert(v);
        }
    }
}
int main()
{
    d[0]=0; d[1]=1;
    for(int i=2;i<=45;i++) {
        d[i]=d[i-2]+d[i-1];
    }
    gao();
    int t;
    scanf("%d",&t);
    ll n;
    while(t--) {
        scanf("%I64d",&n);
        if(*se.lower_bound(n)==n)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值