hdu 3635 Dragon Balls 并查集(带权)

Description

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

Input

The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000). 
Each of the following Q lines contains either a fact or a question as the follow format: 
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different. 
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input

       
       
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output

       
       
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
 

题目大意:

初始时,有n个龙珠,编号从1到n,分别对应的放在编号从1到n的城市中。

现在又2种操作:

T A B,表示把A球所在城市全部的龙珠全部转移到B城市。(第一次时,因为A球所在的城市只有一个球,所以只移动1个,如果有多个,则全部移动)。

Q A,表示查询A。要求得到的信息分别是:A现在所在的城市,A所在城市的龙珠数目,A转移到该城市移动的次数(如果没有移动就输出0)

用num来记录个数,times来记录次数,times要到根,因为并查集并不是按照固定顺序输入的可能根节点最后才输入所以要不断更新所以times要用根节点,num数组同样要用根节点



看他们都说是并查集氺题,但是自己一点没思路,看了别人的代码才慢慢搞懂。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int set[200000],num[200000],times[200000];
struct node
{
    int num,times,posion;
} q[20000];
int find(int x)
{
    int y;
    if(set[x]!=x)
    {
        y=set[x];
        set[x]=find(set[x]);
        times[x]+=times[y];
    }
    return set[x];
}
void search(int x,int y)
{
    int xx=find(x);
    int yy=find(y);
    {
        if(xx!=yy)
        {
            set[xx]=yy;
            num[yy]+=num[xx];
            times[xx]++;
        }
    }
}
int main()
{
    int T;
    int n,Q;
    char ch;
    int a,b;
    scanf("%d",&T);
    for(int Case=1; Case<=T; Case++)
    {
        int k=0;
        scanf("%d %d",&n,&Q);

        for(int i=1; i<=n; i++)
        {
            set[i]=i;
            num[i]=1;
            times[i]=0;
        }
        for(int i=0; i<Q; i++)
        {
            getchar();
            scanf("%c",&ch);
            if(ch=='T')
            {
                scanf("%d %d",&a,&b);
                search(a,b);
            }
            else
            {

                scanf("%d",&a);
                q[k].posion=find(a);
                q[k].num=num[q[k].posion];
                q[k++].times=times[a];
            }
        }
        printf("Case %d:\n",Case);
        for(int i=0; i<k; i++)
        {
            printf("%d %d %d\n",q[i].posion,q[i].num,q[i].times);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值