HDU3635 Dragon Balls 并查集

Dragon Balls

 

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000). 
Each of the following Q lines contains either a fact or a question as the follow format: 
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different. 
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

思路:

题意大致就是悟空要去寻找散落在各个城市中的龙珠,原本龙珠的编号就是城市的编号,但是会有一种操纵T使得城市A中的龙珠转到城市B中,另一种操作Q是询问你三个东西,1.城市A中的龙珠最终在的城市(并查集的find函数)2.城市A的龙珠现在所处的城市(设B)里面有多少龙珠,3.城市A中的龙珠一共被转移了多少次

问题1很好解,但是问题2,3就升级了,2还好说,可以用一个数组存个数(然而不知道为什么写的就是不对),3的话,真的是不知道怎么写,二维数组存的话就算空间不爆,时间也肯定不行,于是只能在并查集的两个函数搞搞小动作了

原来写的数组存个数就不删了,哪位大佬看出来哪错了一定要告诉我呦

#include<bits/stdc++.h>
using namespace std;
const int maxn = (int)1e4 + 10;
int mp[maxn];
struct node
{
	int x,num,y;//num转移次数 ,y城中龙珠个数 
}f[maxn];
int find(int a)
{
	int temp = f[a].x;
	if (a != f[a].x)
	{
		f[a].x = find(f[a].x);
		f[a].num += f[temp].num; //转移次数 
	}
	return f[a].x;
}
void join(int a,int b)
{
	int fx = find(a),fy = find(b);
	if (fx == fy)
		return ;
	f[fx].x = fy;
	f[fx].num ++;
	f[fy].y += f[fx].y;//龙珠个数 
	f[fx].y = 0;
}
int main()
{
	int t,kase = 1;
	char Q[3];
	scanf("%d",&t);
	while (t --)
	{
		int n,m,a,b;
		scanf("%d %d",&n,&m);
		for (int i = 1;i <= n;i ++)
			f[i].x = i,f[i].num = 0,f[i].y = 1;//mp[i] = 1;
		printf("Case %d:\n",kase++);
		while (m--)
		{
			scanf("%s %d",Q,&a);
			if (Q[0] == 'T')
			{
				scanf("%d",&b);
				join(a,b);
//				int c = find(b),d = find(a);
//				if (c != d)
//				{
//				
//				mp[c] += mp[d];
//				mp[d] = 0;}
			}
			else
			{
				int p = find(a);
				printf("%d %d %d\n",p,f[p].y,f[a].num);
			}
		}
	}
	return 0;
}

代码:

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值