【HDU3709】【Balanced Number】

Balanced Number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2926    Accepted Submission(s): 1341


Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].
 

Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).
 

Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
 

Sample Input
  
  
2 0 9 7604 24324
 

Sample Output
  
  
10 897
 

Author
GAO, Yuan
 

Source
 

Recommend
zhengfeng   |   We have carefully selected several similar problems for you:   3711  3715  3718  3713  3712 


开始的时候不知道该怎么做了。。。。应为支点会有很多种情况。。。 原来题解就是枚举每个支点。。。



#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
int n;
int bits[30];
typedef long long ll;
ll dp[30][30][2500];

ll dfs(int len,int o,int l,bool flag)
{
	if(len <= 0) return l == 0;
	if(!flag && dp[len][o][l] != -1) return dp[len][o][l];
	int end = flag ? bits[len] : 9;
	ll res = 0;
	for(int i=0;i<=end;i++)
	{
		res += dfs(len-1,o,l+(len-o)*i,flag &&(i == end));
	}
	return flag ? res : dp[len][o][l] = res;
}

ll solve(ll x)
{
	if(x < 0) return 0;
	int cnt = 0;
	ll tt = x;
	while(tt > 0)
	{
		bits[++cnt] = tt % 10;
		tt /= 10;
	}
	ll ans = 0;
	for(int i=1;i<=cnt;i++)
	{
		ans += dfs(cnt,i,0,true);
	}
	return ans-(cnt-1);

}
int main()
{
    scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		ll l,r;
		memset(dp,-1,sizeof(dp));
		scanf("%I64d%I64d",&l,&r);
		printf("%I64d\n",solve(r)-solve(l-1));
	}
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值