【ZOJ3261】【离线并查集】【逆序】【好题】

Connections in Galaxy War

Time Limit: 3 Seconds       Memory Limit: 32768 KB

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers ab (0 <= ab <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

  • "destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and starb was available before the monsters' attack.

    "query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1

Author:  MO, Luyi
Source:  ZOJ Monthly, November 2009
Submit     Status



#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;

#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define mp push_back

int n,m,q;
const int maxn = 50010;
int p[maxn];
struct Edge
{
    int v,del;
};
struct Qnode
{
    int x,y;
    int type;
};
vector<Edge>g[maxn];
Qnode a[50010];
int ans[50010];

int F[50010];
int Find(int x)
{
    return F[x] == -1 ? x : F[x] = Find(F[x]);
}

void Merge(int x,int y)
{
    int fx = Find(x);
    int fy = Find(y);
    if(fx != fy)
    {
        if(p[fx] > p[fy] || p[fx] == p[fy] && fx < fy)
        {
            F[fy] = fx;
        }
        else 
		{
            F[fx] = fy;
        }
    }
}
int main()
{
    bool first = true;
    while(scanf("%d",&n) != EOF)
    {
        if(!first) puts("");
        if(first) first = false;
		for(int i=0;i<n;i++)
		{
			F[i] = -1;
		}
        for(int i=0;i<n;i++) 
		{
			scanf("%d",&p[i]);
			g[i].clear();
		}
        scanf("%d",&m);
        Edge e;
        e.del = 0;
        for(int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            e.v = u;
            g[v].push_back(e);

            e.v = v;
            g[u].push_back(e);
        }

        scanf("%d",&q);
        char str[10];
        for(int i=0;i<q;i++)
        {
            scanf("%s",str);
            int x,y;
            if(str[0] == 'q')
            {
                scanf("%d",&x);
                a[i].type = 0;
                a[i].x = x;
            }
            else
            {
                scanf("%d%d",&x,&y);
                a[i].type = 1;
                a[i].x = x;
                a[i].y = y;
                for(int k=0;k<g[x].size();k++)
                {
                    if(g[x][k].v == y)
                    {
                        g[x][k].del = 1;
						break;
                    }
                }
                for(int k=0;k<g[y].size();k++)
                {
                    if(g[y][k].v == x)
                    {
                        g[y][k].del = 1;
						break;
                    }
                }
            }
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<g[i].size();j++)
            {
                Edge e = g[i][j];
                if(e.del == 0)
                {
                    Merge(i,e.v);
                }
            }
        }
		for(int i=0;i<q;i++)
			ans[i] = 0x3f3f3f3f;
        int tmp;
        for(int i=q-1;i>=0;i--)
        {
            Qnode node = a[i];
            if(node.type == 0)
            {
				int fa = Find(node.x);
                if(p[fa] > p[node.x])
                {
                    tmp = fa;
                }
                else
                    tmp = -1;
                ans[i] = tmp;
            }
            else
            {
                Merge(node.x,node.y);
            }
        }

        for(int i=0;i<q;i++)
        {
            if(ans[i] != 0x3f3f3f3f)
            {
                printf("%d\n",ans[i]);
            }
        }

    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值