我们倒着来做。删边变成加边。这样就变成裸的并查集维护联通分量
In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.
In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.
Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.
Input
There are no more than 20 cases. Process to the end of file.
For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0, p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers a, b (0 <= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.
In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.
"destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.
"query a" - star a wanted to know which star it should turn to for help
There is a blank line between consecutive cases.
Output
For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.
Print a blank line between consecutive cases.
Sample Input
2 10 20 1 0 1 5 query 0 query 1 destroy 0 1 query 0 query 1
Sample Output
1 -1 -1 -1
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<map>
#include<utility>
#include<iterator>
using namespace std;
#define MAXN 10010
struct query
{
int tp;
int a,b,c;
}qu[50010];
map<pair<int,int> ,int> edge;
int n,m,q;
int v[MAXN],mx[MAXN];
int set[MAXN];
void init(int n)
{
for(int i=0;i<=n;i++)
set[i]=i;
}
int find(int a)
{
int root=a;
int temp;
while(set[root]!=root)
root=set[root];
while(set[a]!=root)
{
temp=a;
a=set[a];
set[temp]=root;
}
return root;
}
bool merge(int a,int b)
{
int x=find(a);
int y=find(b);
if(x==y)
return false;
if(v[mx[y]]<v[mx[x]] || v[mx[y]]==v[mx[x]]&&mx[y]>mx[x])
mx[y]=mx[x];
set[x]=y;
return true;
}
int main()
{
bool fg=0;
while(~scanf("%d",&n))
{
if(fg) printf("\n");
fg=1;edge.clear();
for(int i=0;i<n;i++)
{
scanf("%d",&v[i]);
mx[i]=i;
}
init(n);
int x,y;
scanf("%d",&m);
for(int i=1;i<=m;i++)
{
scanf("%d%d",&x,&y);
if(x>y) swap(x,y);
edge[make_pair(x,y)]=0;
}
scanf("%d",&q);
for(int i=1;i<=q;i++)
{
char tas[10];
scanf("%s",tas);
if(tas[0]=='q')
{
qu[i].tp=0;
scanf("%d",&qu[i].a);
}
else
{
qu[i].tp=1;
scanf("%d%d",&qu[i].a,&qu[i].b);
if(qu[i].a>qu[i].b) swap(qu[i].a,qu[i].b);
edge[make_pair(qu[i].a,qu[i].b)]=1;
}
}
map<pair<int,int>,int>::iterator mi;
mi=edge.begin();
for(;mi!=edge.end();mi++)
{
if(mi->second==0)
merge(mi->first.first,mi->first.second);
}
for(int i=q;i>0;i--)
{
if(qu[i].tp==0)
{
if(v[mx[find(qu[i].a)]]>v[qu[i].a])
qu[i].c=mx[find(qu[i].a)];
else
qu[i].c=-1;
}
else
merge(qu[i].a,qu[i].b);
}
for(int i=1;i<=q;i++) if(qu[i].tp==0)
printf("%d\n",qu[i].c);
}
return 0;
}