排列组合

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

In how many ways can you choose k elements out of n elements, not taking order into account? 
Write a program to compute this number.

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two integers n (n>=1) and k (0<=k<=n). 
Input is terminated by two zeroes for n and k.

Output

For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 2  31
Warning: Don't underestimate the problem. The result will fit into an integer - but if all intermediate results arising during the computation will also fit into an integer depends on your algorithm. The test cases will go to the limit. 

Sample Input

4 2
10 5
49 6
0 0

Sample Output

6
252
13983816
题目的含义就是从m里面挑n个数,组合。
解答:
#include<stdio.h>
int main()
{
    long long  a,b,i,t;//采用long long 接受数据
    while(scanf("%I64d %I64d",&a,&b)!=EOF)
    {
        if(a==0&&b==0)
            break;
        long long s=1;
        t=b;
        if(b>a-b)
        {
            t=a-b;
        }
       for(i=1;i<=t;i++)//由于上下的个数为a-b+1,采用同时的方式防止数据过大!!
       {
           s=s*(a-i+1)/i;
       }
       printf("%I64d\n",s);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值