[An AC a day]1003_HIT_ACM

Mixing Milk

My Tags  (Edit)
  Source : Unknown
  Time limit : 3 sec   Memory limit : 32 M

Submitted : 8061, Accepted : 3407

Since milk packaging is such a low margin business, it is important to keep the price of the raw product (milk) as low as possible. Help Merry Milk Makers get the milk they need in the cheapest possible manner.

The Merry Milk Makers company has several farmers from which they may buy milk, and each one has a (potentially) different price at which they sell to the milk packing plant. Moreover, as a cow can only produce so much milk a day, the farmers only have so much milk to sell per day. Each day, Merry Milk Makers can purchase an integral amount of milk from each farmer, less than or equal to the farmer's limit.

Given the Merry Milk Makers' daily requirement of milk, along with the cost per gallon and amount of available milk for each farmer, calculate the minimum amount of money that it takes to fulfill the Merry Milk Makers' requirements.

Note: The total milk produced per day by the farmers will be sufficient to meet the demands of the Merry Milk Makers.

Input

The first line contains two integers, N and M. The first value, N, (0 <= N <= 2,000,000) is the amount of milk that Merry Milk Makers' want per day. The second, M, (0 <= M <= 5,000) is the number of farmers that they may buy from.

The next M lines (Line 2 through M+1) each contain two integers, Pi and Ai. Pi (0 <= Pi <= 1,000) is price in cents that farmer i charges. Ai (0 <= Ai <= 2,000,000) is the amount of milk that farmer i can sell to Merry Milk Makers per day.

Output

A single line with a single integer that is the minimum price that Merry Milk Makers can get their milk at for one day.

Sample Input
100 5 5 20 9 40 3 10 8 80 6 30
Sample Output
630

#include<stdio.h>
#include<stdlib.h>
#define N 5000
int main()
{
	int n,m,min,sum = 0,price = 0,flag;
	//对N,M的输入
	scanf("%d%d",&n,&m);
	//动态二维数组的建立
	int **person;
	person = (int **)malloc(sizeof(int)*m);
	for(int i = 0;i<m;i++)
	{
		person[i] = (int *)malloc(sizeof(int)*2);
	}
	//数据的储存
	for(int i = 0;i<m;i++)
	{
		scanf("%d%d",&person[i][0],&person[i][1]);
	}
	//主题程序
	while(sum < n)
	{
		min = 1500;
		//找到最小单价
		for(int i = 0;i<m;i++)
		{
			min = (min < person[i][0])?min:person[i][0];
		}
		//找到最小单价所在数组的索引
		for(int i = 0;i<m;i++)
		{
			if(person[i][0] == min)
			{
				flag = i;
				person[i][0] = 1500;
				break;
			}
		}
		//判断是否结束循环以及计算支出
		sum += person[flag][1];
		if(sum <n)
		{
			price += min*person[flag][1];
		}
		else
		{
			price += min*(sum - n);
		}
	}
	//输出
	printf("%d\n",price);

	return 0;
}



写了2份代码,两份代码的区别主要在二维动态数组的建立。

<1003[0].cpp>
//动态二维数组的建立
int **person;
person = (int **)malloc(sizeof(int)*m);
for(int i = 0;i
{
    person[i] = (int *)malloc(sizeof(int)*2);
}
<1003[1].cpp>
//动态二维数组的建立
int (*person)[2];
person = (int (*)[2])malloc(sizeof(int)*m*2);

第一份是常规建立方法。
对第二份进行一个分析:

数组指针(也称行指针)
定义 int (*p)[n];
()优先级高,首先说明p是一个指针,指向一个整型的一维数组,这个一维数组的长度是n,也可以说是p的步长。也就是说执行p+1时,p要跨过n个整型数据的长度。

如要将二维数组赋给一指针,应这样赋值:
int a[3][4];
int (*p)[4]; //该语句是定义一个数组指针,指向含4个元素的一维数组。
p=a;        //将该二维数组的首地址赋给p,也就是a[0]或&a[0][0]
p++;       //该语句执行过后,也就是p=p+1;p跨过行a[0][]指向了行a[1][]

 
所以说第二份和第一份定义出的二维数组实际上是等价的。

但是第二份定义的动态二维数组只能是a[m][N](N为常数)而不能对N进行一个动态定义。有一定局限性。而且较第一份难以理解。应当避免。




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值