POJ 2239-Selecting Courses(二分图_最大匹配+哈希建图)

12 篇文章 0 订阅

Selecting Courses
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8781 Accepted: 3922

Description

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more as possible. Of course there should be no conflict among the courses he selects. 

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks, a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him? 

Input

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming's college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <= 7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

Output

For each test case, output one integer, which is the maximum number of courses Li Ming can select.

Sample Input

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

Sample Output

4

题意:有n门课程可以选择,接下来n行(编号为从1-n),每行第一个数k,代表该门课程上课的时间点,接下来2*k个,每两个为一组(p,q)代表该节课在星期q的p班开始(一个12个班,一周7天)。求最多可以上几门课。

思路:如果不加上他的构图方式,就是一个纯的二分图求最大匹配。建图方式采用哈希表的方式,用p*12+q的方式存取,顺便还可以处理冲突。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
int map[510][510];
int vis[510];
int link[510];
int n;
int dfs(int u)
{
    int i;
    for(i=1;i<=510;i++){
        if(map[u][i]&&!vis[i]){
            vis[i]=1;
            if(link[i]==-1||dfs(link[i])){
                link[i]=u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int i,j,k;
    int p,q;
    int sum;
    while(~scanf("%d",&n)){
    memset(link,-1,sizeof(link));
    memset(map,0,sizeof(map));
    for(i=1;i<=n;i++){
        scanf("%d",&k);
        while(k--){
            scanf("%d %d",&p,&q);
            //map[p*12+q][i]=1;
            map[i][p*12+q]=1;
        }
    }
    sum=0;
    for(i=1;i<=n;i++){
        memset(vis,0,sizeof(vis));
        if(dfs(i))
            {
                //printf("%d---->",dfs(i));
                sum++;
            }
    }
    printf("%d\n",sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值