POJ 2506:Tiling

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7452 Accepted: 3639

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

题目大意就是有2×1和2×2两种规格的地板,现要拼2×n的形状,共有多少种情况。
递推思想:
假设我们已经铺好了2×(n-1)的情形,则要铺到2×n则只能用2×1的地板
假设我们已经铺好了2×(n-2)的情形,则要铺到2×n则可以选择1个2×2或两个2×1,故可能有下列三种铺法

    

其中要注意到第三个会与铺好2×(n-1)的情况重复,故不可取,故可以得到递推式

a[i]=2*a[i-2]+a[i-1];

而且是大数问题。。前面用JAVA水过特别爽。。所以这题也是用JAVA写的。


import java.math.BigInteger;
import java.util.Scanner;
public class Main{


	public static void main(String[] args) {
		Scanner cin=new Scanner(System.in);
		    int n;
		    BigInteger[] a = new BigInteger[300];
			a[0]=BigInteger.ONE;
			a[1]=BigInteger.ONE;
			a[2]=BigInteger.valueOf(3);
			for(int i=2;i<a.length;i++)
			{
				a[i]=a[i-1].add(a[i-2].multiply(BigInteger.valueOf(2)));
			}
			while (cin.hasNext()){
				n=cin.nextInt();
				System.out.println(a[n]);
			}
	}

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值