hdoj1002--A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

/

简单题:大数的运算

注意格式(Case的首字母大写、各种空格、每一行之间有空行,最后一行没有空行)!

给出几组测试数据:

6
1 2
1 0
9999 1
1 999999
5555 4445
112233445566778899 998877665544332211
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

void solve()
{
	int n,i,j,k,flag,t,cas,L;
	char a[1001],b[1001],c[1002];
	scanf("%d",&n);
	getchar();
	cas=1;
	while(n--)
	{
		flag=0;
		memset(a,'\0',sizeof(a));
		memset(b,'\0',sizeof(b));
		memset(c,'\0',sizeof(c));
		scanf("%s",a);
		scanf("%s",b);
		printf("Case %d:\n",cas);
		printf("%s",a);
		printf(" + ");
		printf("%s",b);
		printf(" = ");
		strrev(a);
		strrev(b);
		k=i=0;
		L=(strlen(a)>strlen(b)?strlen(b):strlen(a));
		while(i<L)
		{
			t=(a[i]-'0')+(b[i]-'0')+flag;
			flag=(t>=10?1:0);
			c[k++]=t%10+'0';
			i++;
		}
		if(a[i]=='\0')
		{
			while(b[i]!='\0') {
				t=b[i++]-'0'+flag;
				c[k++]=t%10+'0';
				flag=(t>=10?1:0);
			}
		}
		else
		{
			while(a[i]!='\0') {
				t=a[i++]-'0'+flag;
				c[k++]=t%10+'0';
				flag=(t>=10?1:0);
			}
		}
		if(flag) c[k]='1';
		else k--;
		while(k>=0)
		{
			printf("%c",c[k]);
			k--;
		}
		printf("\n");
		if(n>0) printf("\n");
		cas++;
	}
}

int main()
{
	solve();
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值