1009. Product of Polynomials (25)

1009. Product of Polynomials (25)

Question
This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

#include <iostream>

const int MAX = 1001; //次数从0--1000也就是1001个,而不是1000个!

using namespace std;

int main(int argc, const char * argv[]) {
    int K = 0; //最高次

    //读取第一个多项式的数据
    int K1;
    cin >> K1;

    double vector1[MAX] = {0}; //注意类型!
    int exponent;
    double coefficient; //注意类型!
    for (int i = 0; i < K1; ++i) {
        cin >> exponent >> coefficient;
        vector1[exponent] = coefficient;
        if (i == 0) {
            K = exponent;
        }
    }

     //读取第二个多项式的数据
    int K2;
    cin >> K2;

    double vector2[MAX] = {0};
    for (int i = 0; i < K2; ++i) {
        cin >> exponent >> coefficient;
        vector2[exponent] = coefficient;
        if (i == 0 && exponent > K) {
            K = exponent;
        }
    }

    //计算多项式的乘积
    double polynomial[2*MAX] = {0};
    for (int i = K; i >= 0; --i) {
        for (int j = K; j >= 0; --j) {
            polynomial[i+j] += vector1[i] * vector2[j];
        }
    }

    //统计非零项的个数
    int nonZero = 0;
    for (int i = 2 * K; i >= 0; --i) {
        if (polynomial[i] != 0) {
            ++nonZero;
        }
    }
    cout << nonZero;

    //输出所有非零项
    for (int i = 2 * K; i >= 0; --i) {
        if (polynomial[i] != 0) {
            printf(" %d %.1f",i,polynomial[i]); //注意保留一位小数
        }
    }
    cout << endl;

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值