HDU 2639 - Bone Collector II(01背包)

Description

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).
 

Sample Input

    
    
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output

  
  
12 2 0

                                                                         

题意:

给出物体的数量N,容量W和K,分别输出N个物体的重量和容量,求出第K大的价值。

思路:

01背包问题。dp[i][j] 表示在i 容量得到的第k大的价值。

使用两个数组a[], b[], 分别储存容量为i 的价值,将两组进行比较更新dp 数组 i 容量下第k大的价值。

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

int v[105], w[105];
int dp[100005][35], a[35], b[35];

int main()
{
    //freopen("in", "r", stdin);
    int T;
    scanf("%d", &T);
    while(T--){
        memset(dp, 0, sizeof(dp));
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        
        int N, W, K;
        scanf("%d %d %d", &N, &W, &K);
        for(int i = 0; i < N; ++i){
            scanf("%d", &v[i]);
        }
        for(int i = 0; i < N; ++i){
            scanf("%d", &w[i]);
        }
        
        for(int i = 0; i < N; ++i){
            for(int j = W; j >= w[i]; --j) {
               for(int k = 1; k <= K; ++k){
                  a[k] = dp[j - w[i]][k] + v[i];
                  b[k] = dp[j][k];
               }
                int aa = 1, bb = 1, cc = 1;
                while(cc <= K && (aa <= K || bb <= K)){ //合并重新生成前k个最优解
                    if(a[aa] > b[bb]){
                        dp[j][cc] = a[aa];
                        aa ++;
                    }
                    else{
                        dp[j][cc] = b[bb];
                        bb ++;
                    }
                    if(dp[j][cc] != dp[j][cc - 1]) cc++;
                }
            }
        }
        
        printf("%d\n", dp[W][K]);
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值