HDU2639(第k优解)

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3987    Accepted Submission(s): 2068


Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 231).
 

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
12 2 0
需要将 dp 数组开成一个二维的记录,加上了一个从1到k的值,其他和01一样,其次还有去重的地方需要处理一下
首先dp[i][j]代表的是在体积为i的时候第j优解为dp[i][j]......那么,我们就可以这样思考,i 对应体积,那么如果只是一维的dp[i],代表的应该是体积为i时的最大值,那么同理,dp[i][1]代表的是体积为 i 时的最大值,那么我们就可以退出两种动态,dp[i][m],dp[i-s[i][0]][m]+s[i][1].....然后把这两种状态开个两个数组分别保存起来,再合并出体积为i时的前k优解......依次后推,直到dp[v][k].......
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int V[1010];
int w[1010];
int f[1010][40];
int s1[40];
int s2[40];

int main()
{
    int T;
    scanf("%d",&T);
    while( T--)
    {
        ///memset(V,0,sizeof(V));
        ///memset(w,0,sizeof(w));
        int n,v,k;
        scanf("%d%d%d",&n,&v,&k);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&w[i]);
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&V[i]);
        }
        memset(f,0,sizeof(f));
        if(k==0)
        {
            printf("0\n");
            continue;
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=v;j>=V[i];j--)
            {
                for(int K=1;K<=k;K++)
                {
                    s1[K]=f[j-V[i]][K]+w[i];
                    s2[K]=f[j][K];
                }
                s1[k+1]=s2[k+1]=-1;
                int t=1,x=1,y=1;
                while(t<=k&&(x<=k||y<=k))
                {
                    if(s1[x]>s2[y])
                        f[j][t]=s1[x++];
                    else
                        f[j][t]=s2[y++];
                    if(t==1||f[j][t]!=f[j][t-1])       //这是去重.....
                        t++;
                }
            }
        }


        printf("%d\n",f[v][k]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值