UVA 714 Copying Books(二分查找)(未a)

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers. 

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered 1, 2 ... m) that may have different number of pages (p1, p2 ... pm) and you want to make one copy of each of them. Your task is to divide these books among k scribes, k <= m. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 0 = b0 < b1 < b2, ... < b k-1 <= bk = m such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment. 

Input 

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, 1 <= k <= m <= 500. At the second line, there are integers p1, p2, ... pm separated by spaces. All these values are positive and less than 10000000. 

Output 

For each case, print exactly one line. The line must contain the input succession p1, p2, ... pm divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character ('/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash. 

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book. 

Sample Input 

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

Sample Output 

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

一.总结

题意:按顺序给你N个数,将这N个数分成连续的M段,使得这M段每段的和中的最大值最小,输出最小值(1<=N<=100000,1<=M<=N,每个数在1到10000之间),如果有多种可能的话,尽量在前面进行划分。
首先以正常的思路去考虑优化这个最大值的最小化问题,好像会陷入到循环之中找不到解决的思路,但是我们如果采用猜测-判断-重来的方法不断的去尝试二分查找最大值的最小值,然后去判断这个值是否合法,进一步优化这个值,就可以解决。
那么我们可以将这个思路进行推广,如果我们再次遇到了就求解一个值的问题,我们可以通过查找的方式,进行元算,之后根据运算结果进行进一步优化,最后取得最终答案。
//
//  main.cpp
//  UVa 714
//
//  Created by 张嘉韬 on 16/7/3.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace  std;
const int maxn=510;
int k,m,a[maxn];
long long tol;
void init()
{
    memset(a,0,sizeof(a));
    cin>>m>>k;
    tol=0;
    for(int i=1;i<=m;i++) {cin>>a[i]; tol+=a[i];}
    //cout<<"shit"<<endl;
}
int judge(int x)
{
    int sum=0,counter=k;
    for(int i=1;i<=m;i++)
    {
        if(sum+a[i]<=x)sum+=a[i];
        else
        {
            counter--;
            if(counter==0) return 0;
            sum=a[i];
        }
    }
    return 1;
}
void fun(int *temp,int p,int j)
{
    for(int i=j;i>=1;i--)
    {
        temp[p++]=a[i];
        if(i!=1) temp[p++]=-1;
    }
}
void print(int x)
{
    ///for(int i=1;i<=m;i++) cout<<a[i]<<" "; cout<<endl;
    int temp[2*maxn],p=1,sum=0,counter=k;
    memset(temp,0,sizeof(temp));
    for(int i=m;i>=1;i--)
    {
        if(i==counter) {fun(temp,p,i);break;}
        if(sum+a[i]<=x) {sum+=a[i];temp[p++]=a[i];}
        else
        {
            temp[p++]=-1;
            temp[p++]=a[i];
            sum=a[i];
            counter--;
        }
    }
    for(int i=m+k-1;i>=1;i--)
    {
        if(temp[i]==-1) cout<<"/ ";
        else cout<<temp[i]<<" ";
    }
    cout<<endl;
}
int search(int s,int e)
{
    if(s==e) return s;
    int m=(s+e)/2;
    if(judge(m)==0) return search(m+1,e);
    else return search(s,m);
}
int main(int argc, const char * argv[]) {
    //freopen("/Users/zhangjiatao/Desktop/input.txt","r",stdin);
    int t;
    cin>>t;
    for(int i=1;i<=t;i++)
    {
        init();
        int ans=search(0,tol);
        print(ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值