题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2071
Max Num
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 15386 Accepted Submission(s): 9574
Problem Description
There are some students in a class, Can you help teacher find the highest student .
Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
Output
For each case output the highest height, the height to two decimal plases;
Sample Input
2 3 170.00 165.00 180.00 4 165.00 182.00 172.00 160.00
Sample Output
180.00 182.00
直接排序喽,取最大的了。当然还可以直接扫一遍
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
double a[10005];
int main()
{
int n,t;
cin>>t;
while(t--)
{
cin>>n;
for(int i=0;i<n;i++) cin>>a[i];
sort(a,a+n);
printf("%.2lf\n",a[n-1]);
}
return 0;
}