杭电2588 GCD(欧拉函数+gcd的应用)

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1080    Accepted Submission(s): 492


Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
  
  
3 1 1 10 2 10000 72
 

Sample Output
  
  
1 6 260
/*
x从1到N ,GCD(N,x)>=M的个数,用欧拉函数可以求出来1--N与N互质的个数,找到1--N中是N的约数且大于M的值x,1--N/x的欧拉函数值就是x--N之间比M大的个数,不太明白为什么不会重复,应该是因为x是N的约数吧
加油!!!
Time:2014-9-16 11:44
*/
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int MAX=10000+10;
int N,M;
int num[MAX];
int Eular(int M){
	int ans=M;
	int sq=M;
	for(int i=2;i*i<=sq;i++){
		if(M%i==0){
			ans=ans/i*(i-1);
			while(M%i==0)M/=i; 
		}
	}
	if(M>1)ans=ans/M*(M-1);
	
	return ans;
}
void solve(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&N,&M);
		int i,k=0;
		for(i=1;i*i<N;i++){if(N%i==0){
				if(N/i>=M)
					num[k++]=i;
				if(i>=M)
					num[k++]=N/i;	
			} 
			
		}
		if(i*i==N&&i>=M){
		num[k++]=i;
		}
		int ans=0;
		for(int i=0;i<k;i++)
			ans+=Eular(num[i]);
			
		printf("%d\n",ans);
	}
}
int main(){
	solve();
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值