hdu 2588(欧拉函数)

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1834    Accepted Submission(s): 917


Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
  
  
3 1 1 10 2 10000 72
 

Sample Output
  
  
1 6 260


题目传送门:点击打开链接

首先,对于这题我一开始的思路就有错,后来一看题目中提到欧拉函数才知道这道题一定跟欧拉函数有关。

可是欧拉函数只能求x<=n ,(x,n)=1的x符合条件的个数,而本题是求出(x,n)>=m的个数。

怎么才能把题目要求的转换为求(x,n)=1的个数呢

我们先设整数a,n  a<=n并且(a,n)=d; 根据最大公因数性质可得到(a/d,n/d)=1,我们令q=a/d,因为a<=n, 所以 0<a/d<=n/d;即0<q<=n/d;(所以我们求出有多少个q符合 (q,n/d)=1就是我们求出有多少个a符合(a,n)=d的个数)这是求本题的关键。这个个数用欧拉函数φ(n/d)就可以得出。接下来 我们只要找出n的因子>=m就可以得到本题的答案。

但是从1枚举到n找出因子会超时,那怎么办呢?

我们可以看一下设a,b都是n的因子且a*b=n,a<=b当我们枚举到a的时候 因子b可以由 n/a得到,所以我们只需枚举1到sqrt(n)就能得出n所有的因子了。接下来只需判断因子是否>=m就可以了。还需要注意 φ(n/d)求的是与n/d互素的个数 所以这里的每个与n/d互素的整数x都小于n/d,所以x*d<n,没有算n本身,在最后加一就可以了。

代码如下:


#include <iostream>
#include <cstdio>
using namespace std;
typedef long long  ll;
ll phi(ll n)
{
    ll i,rea=n;
    for(i=2;i*i<=n;++i)
    {
        if(n%i==0)
        {
            rea=rea-rea/i;
            while(n%i==0)
                n/=i;
        }
    }
    if(n>1)
        rea=rea-rea/n;
    return rea;
}
int main(int argc, const char * argv[])
{
    ll m,n;
    int t;
    cin>>t;
    while(t--)
    {
        scanf("%lld%lld",&n,&m);
        if(m==1)
        {
            cout<<n<<endl;
            continue;
        }
        ll ans=0;
        for(ll i=2;i*i<=n;++i)
        {
            if(n%i==0)
            {
                if(i>=m)
                {
                    ll k=phi(n/i);
                    ans+=k;
                }
                if(n/i!=i&&n/i>=m)
                {
                    ll k=phi(i);
                    ans+=k;
                }
            }
        }
        cout<<ans+1<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值