poj1338 Ugly Numbers(技巧)

Ugly Numbers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20846 Accepted: 9244

Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ... 
shows the first 10 ugly numbers. By convention, 1 is included. 
Given the integer n,write a program to find and print the n'th ugly number. 

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10
/*
呵呵………………这道题。。。。。。。加油!!!
Time:2014-11-30 20:39
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main(){
	int n;
	int f[1502];
	memset(f,0,sizeof(f));f[1]=1;
	int pos2=1,pos3=1,pos5=1;
	int v2,v3,v5;
	for(int i=2;i<=1501;i++){
		v2=f[pos2]*2;
		v3=f[pos3]*3;
		v5=f[pos5]*5;
		f[i]=min(v2,min(v3,v5));
		if(f[i]==v2)pos2++;
		if(f[i]==v3)pos3++;
		if(f[i]==v5)pos5++;
	}
	while(scanf("%d",&n)!=EOF,n){
		printf("%d\n",f[n]);
	}
return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值