1016. Phone Bills (25)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day. 

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer. 

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80
个人认为这个题目最麻烦的地方在于如何计算一个时间段的费用,第一次做的时候用了很多for循环,相当麻烦,还容易出错,后来想了一个比以前简单的方法。用一个toll[i]
记录一天之内从第0分钟到第i分钟之间的总费用(1<=i<=1440),这样任意两个时间段之间的费用可以用toll[i]-toll[j]计算。如果大家有更简单的方法欢评论中分享
关闭stdio同步之后由于cout 与printf混用导致输出混乱结果全是错误的不能通过,所以还是不要关同步了。
#include <iostream>
#include <map>
#include <vector>
#include <algorithm>
#include <string>
#include <iomanip>
#include <stdio.h>
using namespace std;
struct bill
{
	string name;
	int month;
	int time;
	bool valid;
	int status;
	bill():valid(true){}
	bool operator<(const bill & b)const
	{
		if(name<b.name)return true;
		else if(name == b.name && time < b.time)return true;
		else return false;
	}
};
inline void print_time(int time){printf("%02d:%02d:%02d",time/1440,(time-1440 *(time/1440))/60,time%60);}
int main()
{
	//ios::sync_with_stdio(false);
	vector<int> toll_per_min(24);
	vector<int> toll(1500,0);
	for(int i=0;i<24;i++)
		cin>>toll_per_min[i];
	for(int i=1;i<=60*24;i++)
		toll[i]=toll_per_min[(i-1)/60]+toll[i-1];
	int n;
	cin>>n;
	vector<bill> bills(n);
	string status;
	int month,day,hh,mm;
	for(int i=0;i<n;i++)
	{
		cin>>bills[i].name;
		scanf("%d:%d:%d:%d",&month,&day,&hh,&mm);
		bills[i].month=month;
		bills[i].time=day*24*60+hh*60+mm;
		cin>>status;
		if(status[1] == 'n')
			bills[i].status=1;
		else
			bills[i].status=0;
	}
	sort(bills.begin(),bills.end());
	map<string,int> paired;
	for(int i=0;i<n;i++)		//pairing
	{
		auto itr = paired.find(bills[i].name);
		if(bills[i].status == 1)
		{
			if(itr != paired.end())
			{
				bills[itr->second].valid=false;
				itr->second=i;
			}
			else
				paired[bills[i].name]=i;
		}
		else
		{
			if(itr != paired.end())
			{
				paired.erase(itr);
			}			
			else
				bills[i].valid=false;
		}
	}
	for(auto itr = paired.begin();itr != paired.end();++itr)
	{
		bills[itr->second].valid=false;
	}
	int last_idx;
	string last_name;
	double total=0.0;
	for(int i=0;i<n;i++)
	{
		if(bills[i].valid == true)
		{
			if(last_name == bills[i].name)
			{
				if(bills[i].status == 1)
				{
					last_idx=i;
				}
				else
				{
					double current_pay=0;
					int diff=bills[i].time-bills[last_idx].time;
					if(bills[i].time % 1440 >= bills[last_idx].time % 1440)
						current_pay=(diff/1440)*toll[1440]+toll[bills[i].time % 1440]-toll[bills[last_idx].time % 1440];
					else
						current_pay=(diff/1440)*toll[1440]+(toll[bills[i].time % 1440])+(toll[1440]-toll[bills[last_idx].time % 1440]);
					print_time(bills[last_idx].time);
					cout<<" ";print_time(bills[i].time);
					printf(" %d $%.2lf\n",diff,current_pay/100.0);
					total+=current_pay;
				}
			}
			else
			{
				if(last_name != "")
				    printf("Total amount: $%.2lf\n",total/100.0);
				last_name=bills[i].name;
				last_idx=i;
				printf("%s %02d\n",bills[i].name.c_str(),bills[i].month);
				total=0;
			}
		}
	}
	printf("Total amount: $%.2lf\n",total/100.0);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值