HDU 1242 Rescue(营救)(优先队列+BFS)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1242


Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15880    Accepted Submission(s): 5756


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13

刚开始一直在超时,原因是输入哪里没有加一个~这个符号,弄了好久,=.=,好无语


#include <iostream>
#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
int m,n;
char mp[220][220];
int dir[4][2] = {{0,1},{1,0},{0,-1},{-1,0}};
typedef struct node
{
    int x,y, step;

};
bool operator < (const node &p,const node &q)
{
    return p.step > q.step;
}
int judge(int x,int y)
{
    if(x<0 || y<0 ||x>=m ||y>=n || mp[x][y]=='#')
        return 0;
    return 1;
}

int bfs(int row,int col)
{
    priority_queue <node> qu;

    node s,out;

    s.x = row;
    s.y = col;
    s.step = 0;

    qu.push(s);

    mp[row][col]='#';

    while(!qu.empty())
    {
        out = qu.top();
        qu.pop();

       // printf("x= %d,y= %d ,step = %d  %c\n",out.x,out.y,out.step,mp[out.x][out.y]);

        for(int i=0; i<4; i++)
        {

            int x = out.x+dir[i][0];
            int y = out.y+dir[i][1];

            if(judge(x,y))
            {
                if(mp[x][y] == 'a')
                {
                    printf("%d\n",out.step+1);
                    return 1;
                }

                s.x = x;
                s.y = y;

                s.step = out.step+1;

                if(mp[x][y]=='x')
                    s.step++;

                qu.push(s);

                mp[x][y]='#';
            }
        }
    }
    return 0;
}
/*
7 8
#.#####.
#..#..r.
#.a#x...
..#..#.#
#...##..
.#......
........

*/
int main()
{
    while(~scanf("%d %d",&m,&n))
    {
        int c,d;
        int i,j;
        for(i=0; i<m; i++)
        {
            scanf("%s",mp[i]);
            for(j=0; j<n; j++)
            {
                if(mp[i][j]=='r')
                {
                    c=i;
                    d=j;
                }
            }
            getchar();
        }

       // printf("mp[1][2]=%c\n",mp[1][2]);
        int flag = bfs(c,d);
        if(flag==0)
            printf("Poor ANGEL has to stay in the prison all his life.\n");
    }
    return 0;
}

//http://acm.hdu.edu.cn/showproblem.php?pid=1242


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设方案旨在通过融合先进技术,如物联网、大数据、人工智能等,实现校园的智能化管理与服务。政策的推动和技术的成熟为智慧校园的发展提供了基础。该方案强调了数据的重要性,提出通过数据的整合、开放和共享,构建产学研资用联动的服务体系,以促进校园的精细化治理。 智慧校园的核心建设任务包括数据标准体系和应用标准体系的建设,以及信息化安全与等级保护的实施。方案提出了一站式服务大厅和移动校园的概念,通过整合校内外资源,实现资源共享平台和产教融合就业平台的建设。此外,校园大脑的构建是实现智慧校园的关键,它涉及到数据中心化、数据资产化和数据业务化,以数据驱动业务自动化和智能化。 技术应用方面,方案提出了物联网平台、5G网络、人工智能平台等新技术的融合应用,以打造多场景融合的智慧校园大脑。这包括智慧教室、智慧实验室、智慧图书馆、智慧党建等多领域的智能化应用,旨在提升教学、科研、管理和服务的效率和质量。 在实施层面,智慧校园建设需要统筹规划和分步实施,确保项目的可行性和有效性。方案提出了主题梳理、场景梳理和数据梳理的方法,以及现有技术支持和项目分级的考虑,以指导智慧校园的建设。 最后,智慧校园建设的成功依赖于开放、协同和融合的组织建设。通过战略咨询、分步实施、生态建设和短板补充,可以构建符合学校特色的生态链,实现智慧校园的长远发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值