POJ3273 Monthly Expense

Problem Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤moneyi ≤ 10,000) that he will need to spend each day over the nextN (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactlyM (1 ≤MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers:N andM
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on theith day

Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input
  
  
7 5 100 400 300 100 500 101 400
Sample Output
  
  
500
把所给的n个数分为m分,使得最大的一份总和最小
#include <stdio.h>
int a[100000],N,M,H,L,D,i,s,p,t;
int f()
{
    for (p=1,i=s=0;i<N;i++)
        if (s+a[i]>D)
        {
            s=a[i];
            p++;
        }
        else s+=a[i];
    if (p>M) return 1;
    else return 0;
}
int main()
{
	int w;//处理整数问题时用一个变量记录当前最佳值,避免向上或向下取整
    scanf("%d%d",&N,&M);
    scanf("%d",&a[0]);
    H=L=a[0];
    for (i=1;i<N;i++)
    {
        scanf("%d",&a[i]);
        H+=a[i];
        if (a[i]>L) L=a[i];
    }
    while(H>=L)//此处要加=,因为相等时的w还未记录
	{
		D=(H+L)/2;
        if (f()) L=D+1;
        else 
	{
		w=D;
		H=D-1;		
	}
    printf("%d",w);
    return 0;
}
//G++输出用%f,C++用%lf

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值