poj1915 Knight Moves

Knight Moves
Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 21449
Accepted: 9977

Description

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 

Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0
一道相似的题,更加直接地给坐标,有几个细节没弄明白
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int map[305][305],n;
int sx,sy,ex,ey;
int to[8][2]={1,2,1,-2,-1,2,-1,-2,2,1,2,-1,-2,-1,-2,1};
struct node
{
    int x,y,st;
};
node s,e;
int check(node p)
{
    if(p.x<0||p.x>=n||p.y<0||p.y>=n||map[p.x][p.y])
    return 1;
    return 0;
}
int bfs()
{
    int i;
    node a,ne;
    memset(map,0,sizeof map);
    queue<node>q;
    s.st=0;
    q.push(s);
    map[s.x][s.y]=1;
    while(!q.empty())
    {
        a=q.front();
        q.pop();
        if(a.x==e.x&&a.y==e.y)
        return a.st;
        for(i=0;i<8;i++)
        {
            ne.x=a.x+to[i][0];
            ne.y=a.y+to[i][1];
            if(check(ne))
           continue;
//        if(ne.x>=0&&ne.x<n&&ne.y>=0&&ne.y<n&&!map[ne.x][ne.y])
//         {//不知道为什么这样写会wa
            ne.st=a.st+1;
//            if(ne.x==e.x&&ne.y==e.y)
//        return ne.st;
            map[ne.x][ne.y]=1;
            q.push(ne);
//        }
        }
    }
}
int main()
{
    int i,j,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        scanf("%d%d%d%d",&s.x,&s.y,&e.x,&e.y);
        printf("%d\n",bfs());
    }
    return 0;
}
这样写也能过
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int map[305][305],n;
int sx,sy,ex,ey;
int to[8][2]={1,2,1,-2,-1,2,-1,-2,2,1,2,-1,-2,-1,-2,1};
struct node
{
    int x,y,st;
};
node s,e;
int bfs()
{
    int i;
    node a,ne;
    memset(map,0,sizeof map);
    queue<node>q;
    s.st=0;
    q.push(s);
    map[s.x][s.y]=1;
    while(!q.empty())
    {
        a=q.front();
        q.pop();
        if(a.x==e.x&&a.y==e.y)
        return a.st;
        for(i=0;i<8;i++)
        {
            ne.x=a.x+to[i][0];
            ne.y=a.y+to[i][1];
            if(ne.x>=0&&ne.x<n&&ne.y>=0&&ne.y<n&&!map[ne.x][ne.y])
             {
                ne.st=a.st+1;
                map[ne.x][ne.y]=1;
                q.push(ne);
            }
        }
    }
    return -1;//不知道为什么不加这一句会wa
}
int main()
{
    int i,j,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        scanf("%d%d%d%d",&s.x,&s.y,&e.x,&e.y);
        printf("%d\n",bfs());
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值