hdu 1083 Courses 【完全匹配】

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3805    Accepted Submission(s): 1815


Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

Sample Input
  
  
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 

Sample Output
  
  
YES NO
 
/*题解:
    完全匹配问题,用匈牙利算法求得。 
*/ 
给定一个二分图G,在G的一个子图M中,M的边集中的任意两条边都不依附于同一个顶点,则称M是一个匹配。
选择这样的边数最大的子集称为图的最大匹配问题(maximal matching problem)
如果一个匹配中,图中的每个顶点都和图中某条边相关联,则称此匹配为完全匹配,也称作完备匹配。
求二分图最大匹配可以用最大流或者匈牙利算法。

#include<cstdio>
#include<cstring>
int n,m,P,N;
int map[1010][1010],vis[1010],st[1010];
bool find(int x)
{
    int j;
    for(j=1; j<=N; j++)
    {
        if(map[x][j]==true&&vis[j]==false)
        {
            vis[j]=1;
            if(st[j]==0||find(st[j]))
            { 
                st[j]=x;
                return true;
            }
        }
    } 
    return false;
} 
int main()
{
    int T,i,j,a,b,ans;
    scanf("%d",&T);
    while(T--)
    {
        memset(map,0,sizeof(map));
        memset(st,0,sizeof(st));
        scanf("%d %d",&P,&N);
        for(i=1; i<=P; i++)
        {
            scanf("%d",&a);
            for(j=1; j<=a; j++)
            {
                scanf("%d",&b);
                map[i][b]=1;
            }
        }
        for(i=1,ans=0; i<=P; i++)
        {
            memset(vis,0,sizeof(vis));
            if(find(i)) ans++;
        }
        if(ans==P)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}











评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值