HDU Triangle LOVE

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2663    Accepted Submission(s): 1070


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
 
/* 
题解:dfs解决,参考网上的代码,一开始以为仅仅需要判断是否有环果断wrong
后来发现题意说“Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
参考网上的dfs解决,但仍然不是很理解。
*/
#include<cstdio>
#include<cstring>
#define maxn 2002
int vis[maxn],dis[maxn],flag,n;
char map[maxn][maxn];

void dfs(int step)
{
	if(flag) return;
	vis[step]=1;
	for(int i=1; i<=n; i++)
	{
		if(map[step][i]=='1')
		{
			if(vis[i]&&dis[step]==dis[i]+2)
			{
				flag=1;
				break;
			}
			else if(!vis[i])
			{
				dis[i]=dis[step]+1;
				dfs(i);
			}
		}
	}
}

int main()
{
	int T,cnt=1;
	scanf("%d",&T);
	while(T--)
	{	
	//	memset(vis,0,sizeof(0));事前初始化就会wrong
		scanf("%d",&n);
		//getchar();
		for(int i=1; i<=n; i++)//字符串这样可以从map[1][1]开始存储
		{
			vis[i]=0;			//必须要这样初始化
			scanf("%s",map[i]+1);//从1开始存储
		}
	
		dis[1]=0;
		flag=0;
		dfs(1);//从1开始搜索
		printf("Case #%d: ",cnt++);
		if(flag) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}





























  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值