LightOJ - 1282 Leading and Trailing

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669


求一个数的后三位大家都会求,只要 mod 1000 就可以了。其实求前三位也很简单,只需要将其变成整数位为一位的浮点型,最后乘以100取整就可以了。比如说12345,可以先变成1.2345,[1.2345*100]=123。乘方计算用快速幂。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
typedef long long LL;

int getlen(long long n)
{
    int len=0;
    while(n)
    {
        n/=10;
        len++;
    }
    return len;
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int tt=1; tt<=t; tt++)
    {
        long long n,k;
        scanf("%lld%lld",&n,&k);
        double m=n/pow(10,getlen(n)-1);
        long long x=n;
        int res = 1,mod = 1000;
        double r=1;
        while(k > 0)
        {
            if(k & 1)
            {
                res = res * x % mod;
                r = r * m;
                while(r>=10)
                {
                    r /= 10;
                }
            }
            x = x * x % mod;
            m = m * m;
            while(m>=10)
            {
                m /= 10;
            }
            k >>= 1;
        }
        printf("Case %d:",tt);
        if(res<10)
            printf(" %d 00%d\n",(int)(r*100),res);
        else if(res<100)
            printf(" %d 0%d\n",(int)(r*100),res);
        else
            printf(" %d %d\n",(int)(r*100),res);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值