HDU-3018 并查集 欧拉回路

Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.
Ant Tony,together with his friends,wants to go through every part of the country.
They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people. So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
Output
For each test case ,output the least groups that needs to form to achieve their goal.
Sample Input
3 3
1 2
2 3
1 3

4 2
1 2
3 4
Sample Output
1
2
解题思路:
并查集找连通块,判断每个连通块(孤立点除外)是否为欧拉回路,
是则++ans,
否则ans+=奇数度点的数量/2;
代码:

#include<bits/stdc++.h>
#define maxn 100001
using namespace std;
inline int read(){
    	int x=0,f=0;char ch=getchar();
    	while(ch>'9'||ch<'0')f|=ch=='-',ch=getchar();
    	while(ch>='0'&&ch<='9')x=(x<<3)+(x<<1)+(ch^48),ch=getchar();
    	return f?-x:x;
}
int n,m,pre[maxn],in[maxn];
int f(int x){return pre[x]==x?x:pre[x]=f(pre[x]);}
void un(int a,int b){
	a=f(a),b=f(b);
	if(a!=b)pre[a]=b;
}
vector<int>q[maxn];
int main(){
	while(~scanf("%d%d",&n,&m)){
		for(int i=1;i<=n;++i)in[i]=0,pre[i]=i,q[i].clear();
		while(m--){
			int u=read(),v=read();
			un(u,v);
			++in[u],++in[v];
		}
		int ans=0;
		for(int i=1;i<=n;++i)q[f(i)].push_back(i);
		for(int i=1;i<=n;++i){
			int cnt=0;
			for(int j=0;j<q[i].size();++j)if(in[q[i][j]]&1)++cnt;
			if(cnt)ans+=cnt/2;
			else if(!q[i].empty()&&q[i].size()!=1)++ans;
		}
		printf("%d\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值