PAT A1114. Family Property


1114. Family Property (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 ... Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi's are the ID's of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000


#include<cstdio>

#include<algorithm>

using namespace std;





const int maxn = 10010;


int father[maxn];

int vis[maxn];

struct person {

    int id,dadId,momId;

    double estate,area;

}p[maxn];


struct rootPerson {

    int id,perple;

    double totalEstate,totalArea;

    bool flag;

}r[maxn];


bool cmp2(struct rootPerson a,struct rootPerson b){

    


    return (a.totalArea)>(b.totalArea);

    

}



bool cmp(struct rootPerson a,struct rootPerson b){

    

    if((a.totalArea/a.perple)==(b.totalArea/b.perple)){

        return a.id<b.id;

    }else{

       return (a.totalArea/a.perple)>(b.totalArea/b.perple);

    }

}


int findFather(int id){

    while(father[id]!=id){

        id = father[id];

    }

    return id;

}


void Union(int a,int b){

    a = findFather(a);

    b = findFather(b);

    if(a<b){

        father[b] = a;

    }else{

        father[a] = b;

    }

}


void initFather(){

    for(int i=0;i<maxn;i++){

        father[i] = i;

    }

    return;

}


int main(){

    initFather();

    int num;

    scanf("%d",&num);

    for(int i=0;i<num;i++){

        int k=0;

        scanf("%d%d%d%d",&p[i].id,&p[i].dadId,&p[i].momId,&k);

        vis[p[i].id] = true;

        if(p[i].dadId!=-1){

            Union(p[i].id, p[i].dadId);

        }

        if(p[i].momId!=-1){

            Union(p[i].id, p[i].momId);

        }

  

        vis[p[i].dadId] = true;

         vis[p[i].momId] = true;

        for(int j=0;j<k;j++){

            int child;

            scanf("%d",&child);

            Union(p[i].id, child);

            vis[child] = true;

        }

        scanf("%lf%lf",&p[i].estate,&p[i].area);

    }

    

    for(int i=0;i<num;i++){

        r[findFather(p[i].id)].flag = true;

        r[findFather(p[i].id)].totalEstate +=p[i].estate;

        r[findFather(p[i].id)].totalArea +=p[i].area;

        r[findFather(p[i].id)].id =findFather(p[i].id);

    }

    int numRoot=0;

    for(int i=0;i<maxn;i++){

        if(vis[i]==true){

            r[findFather(i)].perple++;

            

        }

        if(r[i].flag == true){

            numRoot++;

        }

    }

    printf("%d\n",numRoot);

    sort(r, r+maxn, cmp2);

    sort(r, r+numRoot, cmp);

    for(int i=0;i<numRoot;i++){

        printf("%04d %d %.3f %.3f\n",r[i].id,r[i].perple,r[i].totalEstate/r[i].perple,r[i].totalArea/r[i].perple);

    }

    

    

    return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值