POJ-3276 Face The Right Way

65 篇文章 0 订阅
50 篇文章 0 订阅
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3740 Accepted: 1724

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turnK (1 ≤ KN) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group ofK cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same*location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value ofK that minimizes the number of operations required by the machine to make all the cows face forward. Also determineM, the minimum number of machine operations required to get all the cows facing forward using that value ofK.

Input

Line 1: A single integer: N
Lines 2.. N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

Output

Line 1: Two space-separated integers: K and M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

Source

USACO 2007 March Gold

分析:贪心,枚举K,然后从左到右扫一遍,碰到必须纠正的就转向,最后判断下剩下的部分是不是都朝前。
#include <cstdio>
#include <iostream>
#define MAXN 2147483647
using namespace std;
int n,ans,m,F[5001],f[5001];
char c;
int main()
{
	cin.sync_with_stdio(false);
	cin>>n;
	for(int i=1;i <= n;i++)
	{
		cin>>c;
		F[i]=c == 'F' ? 1 : 0; 
	}
	m=MAXN;
	for(int k=1;k <= n;k++)
	{
		int sum=0,tot=0;
		for(int i=1;i <= n-k+1;i++)
		{
			if( (sum+F[i])%2 == 0 )
			{
				f[i]=1;
				sum=(sum+1)%2;
				tot++;
			}
			else f[i]=0;
			if(i >= k) sum=(sum+f[i-k+1])%2;	
		}
		bool flag=false;
		for(int i=n-k+2;i <= n;i++)
		{
			if((F[i]+sum)%2 == 0)
			 {
		 		flag=true;
		 		break;
		 	 }
		 	if(i >= k) sum=(sum+f[i-k+1])%2;	
		}
		if(flag) continue;
		if(m > tot)
		{
			m=tot;
			ans=k;	
		}
	}
	if(m == 0) ans=0;
	cout<<ans<<" "<<m<<endl;
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值