Hdu-5301 Buildings(思维题)

185 篇文章 0 订阅
116 篇文章 0 订阅
Problem Description
Your current task is to make a ground plan for a residential building located in HZXJHS. So you must determine a way to split the floor building with walls to make apartments in the shape of a rectangle. Each built wall must be paralled to the building's sides.

The floor is represented in the ground plan as a large rectangle with dimensions n×m , where each apartment is a smaller rectangle with dimensions a×b located inside. For each apartment, its dimensions can be different from each other. The number a and b must be integers.

Additionally, the apartments must completely cover the floor without one 1×1 square located on (x,y) . The apartments must not intersect, but they can touch.

For this example, this is a sample of n=2,m=3,x=2,y=2 .



To prevent darkness indoors, the apartments must have windows. Therefore, each apartment must share its at least one side with the edge of the rectangle representing the floor so it is possible to place a window.

Your boss XXY wants to minimize the maximum areas of all apartments, now it's your turn to tell him the answer.
 

Input
There are at most 10000 testcases.
For each testcase, only four space-separated integers, n,m,x,y(1n,m108,n×m>1,1xn,1ym) .
 

Output
For each testcase, print only one interger, representing the answer.
 

Sample Input
  
  
2 3 2 2 3 3 1 1
 

Sample Output
  
  
1 2
Hint
Case 1 :
You can split the floor into five $1 \times 1$ apartments. The answer is 1. Case 2:
You can split the floor into three $2 \times 1$ apartments and two $1\times 1$ apartments. The answer is 2.
If you want to split the floor into eight $1 \times 1$ apartments, it will be unacceptable because the apartment located on (2,2) can't have windows.
 

Author
XJZX
 

Source
2015 Multi-University Training Contest 2


题意给你一个n*m的矩形,可以分成n*m个1*1的小矩形,再给你一个坐标(x,y),表示黑格子在n*m矩形中的位置,黑格子占一个1*1的小矩形的空间,用各种矩形去填充n*m矩形,(x,y)位置不能填,且每个去填充的小矩形都有一边是靠着n*m矩形的外框,求这些填充的小矩形在最小大小情况下的面积最大的矩形面积。

分析:如果没有噪点的话,答案应该是(n+1)/2 (n <= m),加入噪点会使得结果变大(n = m = 2*k+1,且x = y = k + 1时例外),现在讨论一般情况,按照没有噪点的情况去竖着铺设很容易得到 max(x-1,n-x)  的答案,但是此时我们也可以考虑横着铺设一部分,此部分长度为min(y,m-y+1),两者取最小值,但是注意答案不能小于(n+1)/2

#include <cstdio>
#include <iostream>
#define min(a,b) (a) > (b) ? (b) : (a)
#define max(a,b) (a) < (b) ? (b) : (a)
using namespace std;
int n,m,x,y;
int main()
{
    while(cin>>n>>m>>x>>y)
    {
    	if(n == m && x == y && x == (n+1)/2 && n % 2) 
		{
			cout<<x-1<<endl;
			continue;
		}
        if(n > m) swap(n,m),swap(x,y);
        int ans = min(max(x-1,n-x),min(y,m-y+1));
		ans = max((n+1)/2,ans);
        cout<<ans<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值