Hdu-5773 The All-purpose Zero(LIS变形)

185 篇文章 0 订阅
116 篇文章 0 订阅
Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 

Sample Input
  
  
2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0
 

Sample Output
 
 
Case #1: 5 Case #2: 5
Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5. 题意:给你一个含零的序列,问其最长不降子序列(严格单调),其中零可以化为任何数。 分析:如果在最优方案中的两个数a b 中间存在一个0,那么用0代替a 或 b一定不会使结果变差,所以我们要选上所有的0,于是我们把每个非零数减去它前边零的个数后求LIS。
#include <cstdio>
#include <stack>
#include <queue>    
#include <vector>    
#include <cstdio>    
#include <utility>    
#include <cstring>    
#include <iostream>    
#include <algorithm>    
#define INF 0x3f3f3f3f
using namespace std;
int T,n,tot,num,x,a[100005],f[100005];
int main()
{
	scanf("%d",&T);
	for(int t = 1;t <= T;t++)
	{
		tot = num = 0;
		scanf("%d",&n);
		for(int i = 1;i <= n;i++)
		{
			scanf("%d",&x);
			if(x) 
			{
				x -= tot;
				a[++num] = x;
			}
			else tot++;
		}
		memset(f,INF,sizeof(f));
		for(int i = 1;i <= num;i++)
		{
			int *pos = lower_bound(f+1,f+2+num,a[i]);
			*pos = a[i]; 
		}
		f[0] = 0;
		for(int i = num;i >= 0;i--)
		 if(f[i] < f[100004])
		 {
		  	printf("Case #%d: %d\n",t,i+tot);
		  	break;
		 }
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值